From 2da155a48ec7f44ae9851205494ce53f9a1ed65b Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Wed, 3 Jan 2001 23:43:25 +0000
Subject: Add p5-SOAP 0.28, perl modules providing an API to the Simple Object
 Access Protocol.

---
 net/Makefile            |  1 +
 net/p5-SOAP/Makefile    | 36 ++++++++++++++++++++++++++++++++++++
 net/p5-SOAP/distinfo    |  1 +
 net/p5-SOAP/pkg-comment |  1 +
 net/p5-SOAP/pkg-descr   |  7 +++++++
 net/p5-SOAP/pkg-plist   | 25 +++++++++++++++++++++++++
 6 files changed, 71 insertions(+)
 create mode 100644 net/p5-SOAP/Makefile
 create mode 100644 net/p5-SOAP/distinfo
 create mode 100644 net/p5-SOAP/pkg-comment
 create mode 100644 net/p5-SOAP/pkg-descr
 create mode 100644 net/p5-SOAP/pkg-plist

diff --git a/net/Makefile b/net/Makefile
index 17c65663b910..bce696feae53 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -199,6 +199,7 @@
     SUBDIR += p5-SNMP
     SUBDIR += p5-SNMP-Util
     SUBDIR += p5-SNMP_Session
+    SUBDIR += p5-SOAP
     SUBDIR += p5-Socket6
     SUBDIR += p5-Socks
     SUBDIR += p5-URI
diff --git a/net/p5-SOAP/Makefile b/net/p5-SOAP/Makefile
new file mode 100644
index 000000000000..973bbc9f39c4
--- /dev/null
+++ b/net/p5-SOAP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for:	SOAP
+# Date created:				Wed Jan  3 10:01:46 2001
+# Whom:					will
+#
+# $FreeBSD$
+#
+
+PORTNAME=	SOAP
+PORTVERSION=	0.28
+CATEGORIES=	net perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	SOAP
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	ports@FreeBSD.org
+
+BUILD_DEPENDS=	${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+		${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww perl5
+RUN_DEPENDS=	${BUILD_DEPENDS}
+
+SITE_PERL=	${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5=	yes
+PERL_CONFIGURE=	yes
+
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3=		SOAP.3 SOAP::SimpleTypeWrapper.3 SOAP::Parser.3 \
+		SOAP::EnvelopeMaker.3 SOAP::GenericScalarSerializer.3 \
+		SOAP::Transport::HTTP::Apache.3 SOAP::TypedPrimitiveSerializer.3 \
+		SOAP::GenericInputStream.3 SOAP::Serializer.3 \
+		SOAP::GenericHashSerializer.3 SOAP::OutputStream.3 \
+		SOAP::Transport::HTTP::CGI.3 SOAP::Packager.3 SOAP::Envelope.3 \
+		SOAP::TypedPrimitive.3 SOAP::StructSerializer.3 \
+		SOAP::Transport::HTTP::Server.3 SOAP::Defs.3 SOAP::Struct.3 \
+		SOAP::TypeMapper.3 SOAP::Transport::HTTP::Client.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP/distinfo b/net/p5-SOAP/distinfo
new file mode 100644
index 000000000000..8bbfb05489c1
--- /dev/null
+++ b/net/p5-SOAP/distinfo
@@ -0,0 +1 @@
+MD5 (SOAP-0.28.tar.gz) = 99264062099ea8929c84661e09d5637f
diff --git a/net/p5-SOAP/pkg-comment b/net/p5-SOAP/pkg-comment
new file mode 100644
index 000000000000..423b0f5e76ee
--- /dev/null
+++ b/net/p5-SOAP/pkg-comment
@@ -0,0 +1 @@
+Perl modules providing an API to the Simple Object Access Protocol
diff --git a/net/p5-SOAP/pkg-descr b/net/p5-SOAP/pkg-descr
new file mode 100644
index 000000000000..d3ad370d2cd3
--- /dev/null
+++ b/net/p5-SOAP/pkg-descr
@@ -0,0 +1,7 @@
+SOAP/Perl is a collection of Perl modules which provides a simple
+and consistent application programming interface (API) to the 
+Simple Object Access Protocol (SOAP).
+
+To learn more about SOAP, see http://www.w3.org/TR/SOAP/.
+
+--will
diff --git a/net/p5-SOAP/pkg-plist b/net/p5-SOAP/pkg-plist
new file mode 100644
index 000000000000..3805c50eb598
--- /dev/null
+++ b/net/p5-SOAP/pkg-plist
@@ -0,0 +1,25 @@
+lib/perl5/site_perl/%%PERL_VER%%/SOAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Defs.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Envelope.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/EnvelopeMaker.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/GenericHashSerializer.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/GenericInputStream.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/GenericScalarSerializer.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/OutputStream.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Packager.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Serializer.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/SimpleTypeWrapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Struct.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/StructSerializer.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP/Apache.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP/CGI.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/TypeMapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/TypedPrimitive.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/TypedPrimitiveSerializer.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SOAP/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SOAP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0