From 24e7e57f25be08349cab94ef23662c2207b3dcdf Mon Sep 17 00:00:00 2001
From: Kirill Ponomarev <krion@FreeBSD.org>
Date: Tue, 10 Aug 2004 18:26:27 +0000
Subject: Update to version 0.8.0

PR:		ports/70261
Submitted by:	Ports Fury
---
 editors/hte/Makefile                    | 11 ++++++--
 editors/hte/distinfo                    |  4 +--
 editors/hte/files/patch-cstream.cc      | 35 -------------------------
 editors/hte/files/patch-htle.cc         | 46 ---------------------------------
 editors/hte/files/patch-src::srt_x86.cc | 18 -------------
 5 files changed, 11 insertions(+), 103 deletions(-)
 delete mode 100644 editors/hte/files/patch-cstream.cc
 delete mode 100644 editors/hte/files/patch-htle.cc
 delete mode 100644 editors/hte/files/patch-src::srt_x86.cc

diff --git a/editors/hte/Makefile b/editors/hte/Makefile
index 18a64aa60b9c..edd26b8e16c0 100644
--- a/editors/hte/Makefile
+++ b/editors/hte/Makefile
@@ -7,7 +7,7 @@
 #
 
 PORTNAME=	hte
-PORTVERSION=	0.7.5
+PORTVERSION=	0.8.0
 CATEGORIES=	editors
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
@@ -42,9 +42,16 @@ LDFLAGS=	-L${X11BASE}/lib
 .endif
 
 post-patch:
-	@${REINPLACE_CMD} -e 's|$$FLAGS_PIPE $$FLAGS_ALL|$$CFLAGS|g ; \
+	@${REINPLACE_CMD} -e 's|^CXXFLAGS=.*$$|CXXFLAGS="$$CXXFLAGS"|g ; \
+		 s|^CFLAGS=.*$$|CFLAGS="$$CFLAGS"|g ; \
 		 s|-L/usr/X11/lib -L/usr/X11R6/lib|$$LDFLAGS|g' \
 			${WRKSRC}/configure
+	@${REINPLACE_CMD} -e \
+		's|typedef unsigned int uint;||g' ${WRKSRC}/global.h
+	@${REINPLACE_CMD} -e \
+		's|uint |UINT |g' ${WRKSRC}/htdata.h
+	@${REINPLACE_CMD} -e \
+		's|#include <malloc.h>||g' ${WRKSRC}/cp-demangle.c
 
 post-install:
 .if !defined(NOPORTDOCS)
diff --git a/editors/hte/distinfo b/editors/hte/distinfo
index e569104eb046..a95c05dfac90 100644
--- a/editors/hte/distinfo
+++ b/editors/hte/distinfo
@@ -1,2 +1,2 @@
-MD5 (ht-0.7.5.tar.bz2) = 9c0a9f043d6b4f366a9c60bf594c382d
-SIZE (ht-0.7.5.tar.bz2) = 649346
+MD5 (ht-0.8.0.tar.bz2) = ee309bdd16b3e1ec78b2efb6427dd5a5
+SIZE (ht-0.8.0.tar.bz2) = 731401
diff --git a/editors/hte/files/patch-cstream.cc b/editors/hte/files/patch-cstream.cc
deleted file mode 100644
index 4998254c2217..000000000000
--- a/editors/hte/files/patch-cstream.cc
+++ /dev/null
@@ -1,35 +0,0 @@
---- cstream.cc.orig	Mon Jul  1 02:08:48 2002
-+++ cstream.cc	Wed Aug  4 18:09:28 2004
-@@ -115,12 +115,13 @@
- 	return true;
- }
- 
--UINT	ht_compressed_stream::read(void *buf, UINT size)
-+UINT	ht_compressed_stream::read(void *aBuf, UINT size)
- {
- 	UINT ssize = size;
-+	byte *buf = (byte *)aBuf;
- 	while (size >= bufferpos) {
- 		memcpy(buf, buffer+buffersize-bufferpos, bufferpos);
--		((byte *)buf) += bufferpos;
-+		buf += bufferpos;
- 		size -= bufferpos;
- 		bufferpos = 0;
- 		if (size) {
-@@ -134,13 +135,14 @@
- 	return ssize;
- }
- 
--UINT	ht_compressed_stream::write(const void *buf, UINT size)
-+UINT	ht_compressed_stream::write(const void *aBuf, UINT size)
- {
- 	UINT ssize = size;
-+	const byte *buf = (const byte *)aBuf;
- 	while (bufferpos+size >= buffersize) {
- 		memcpy(buffer+bufferpos, buf, buffersize-bufferpos);
- 		size -= buffersize-bufferpos;
--		((byte *)buf) += buffersize-bufferpos;
-+		buf += buffersize-bufferpos;
- 		bufferpos = buffersize;
- 		if (size) {
- 			if (!flush_compressed()) return ssize - size;
diff --git a/editors/hte/files/patch-htle.cc b/editors/hte/files/patch-htle.cc
deleted file mode 100644
index 17817f7051bd..000000000000
--- a/editors/hte/files/patch-htle.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- htle.cc.orig	Thu Oct 10 03:32:50 2002
-+++ htle.cc	Wed Aug  4 18:14:34 2004
-@@ -475,19 +475,20 @@
- 	return false;
- }
- 
--UINT ht_le_page_file::read(void *buf, UINT size)
-+UINT ht_le_page_file::read(void *aBuf, UINT size)
- {
- 	FILEOFS mofs;
- 	UINT msize;
- 	int c = 0;
- 	while (size) {
- 		UINT s = size;
-+		byte *buf = (byte *)aBuf;
- 		if (!map_ofs(ofs, &mofs, &msize)) break;
- 		if (s>msize) s = msize;
- 		streamfile->seek(mofs);
- 		s = streamfile->read(buf, s);
- 		if (!s) break;
--		((byte*)buf) += s;
-+		buf += s;
- 		size -= s;
- 		c += s;
- 		ofs += s;
-@@ -546,17 +547,18 @@
- 	return ht_layer_streamfile::vcntl(cmd, vargs);
- }
- 
--UINT ht_le_page_file::write(const void *buf, UINT size)
-+UINT ht_le_page_file::write(const void *aBuf, UINT size)
- {
- 	FILEOFS mofs;
- 	UINT msize;
- 	int c = 0;
- 	while (size) {
- 		UINT s = size;
-+		const byte *buf = (const byte *)aBuf;
- 		if (!map_ofs(ofs, &mofs, &msize)) break;
- 		if (s>msize) s = msize;
- 		streamfile->seek(mofs);
--		((byte*)buf) += streamfile->write(buf, s);
-+		buf += streamfile->write(buf, s);
- 		size -= s;
- 		c += s;
- 		ofs += s;
diff --git a/editors/hte/files/patch-src::srt_x86.cc b/editors/hte/files/patch-src::srt_x86.cc
deleted file mode 100644
index 13b69689ab08..000000000000
--- a/editors/hte/files/patch-src::srt_x86.cc
+++ /dev/null
@@ -1,18 +0,0 @@
---- srt/srt_x86.cc.orig	Mon Sep  2 02:05:13 2002
-+++ srt/srt_x86.cc	Wed Aug  4 17:53:58 2004
-@@ -60,13 +60,13 @@
- 		k = &cpu->flags[(idx-8) % X86_FLAGS];
- 		(*k)->done();
- 		delete *k;
--		((Object*)*k) = o;
-+		k = (sym_bool **)o;
- 	} else {
- 		sym_int **k;
- 		k = &cpu->regs[idx & 7];
- 		(*k)->done();
- 		delete *k;
--		((Object*)*k) = o;
-+		k = (sym_int **)o;
- 	}
- }
- 
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0