From 19c823ac69c5b04210909c18d777293505b41622 Mon Sep 17 00:00:00 2001
From: Jun Kuriyama <kuriyama@FreeBSD.org>
Date: Mon, 24 Jun 2002 00:46:44 +0000
Subject: Fix breakage on latest -current.

This breakage is caused because:
  o struct statvfs is defined and statvfs() function is declared.
  o statvfs() function is not yet implemented.

So detection of statvfs related is commented out until function will
be implemented.
---
 net-mgmt/net-snmp-devel/files/patch-al | 61 +++++++++++++++++++++++++++++++---
 net-mgmt/net-snmp/files/patch-al       | 61 +++++++++++++++++++++++++++++++---
 net-mgmt/net-snmp53/files/patch-al     | 61 +++++++++++++++++++++++++++++++---
 net/net-snmp/files/patch-al            | 61 +++++++++++++++++++++++++++++++---
 4 files changed, 228 insertions(+), 16 deletions(-)

diff --git a/net-mgmt/net-snmp-devel/files/patch-al b/net-mgmt/net-snmp-devel/files/patch-al
index c2464056b6bc..c50e4967d041 100644
--- a/net-mgmt/net-snmp-devel/files/patch-al
+++ b/net-mgmt/net-snmp-devel/files/patch-al
@@ -1,6 +1,6 @@
---- configure.in~	Sat May  6 01:46:26 2000
-+++ configure.in	Wed May 17 11:09:08 2000
-@@ -1286,6 +1286,26 @@
+--- configure.in.orig	Tue May  7 08:12:10 2002
++++ configure.in	Mon Jun 24 09:38:33 2002
+@@ -1772,6 +1772,26 @@
  AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
  [
  
@@ -26,4 +26,57 @@
 +
  dnl 4.4 compat
  AC_TRY_COMPILE([
- #include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+@@ -2117,29 +2137,29 @@
+ #endif
+ ],swdevt,sw_nblksenabled)
+ 
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_frsize)
+-
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_files)
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_frsize)
++
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_files)
+ 
+ AC_CHECK_STRUCT_FOR([
+ #if HAVE_NLIST_H
diff --git a/net-mgmt/net-snmp/files/patch-al b/net-mgmt/net-snmp/files/patch-al
index c2464056b6bc..c50e4967d041 100644
--- a/net-mgmt/net-snmp/files/patch-al
+++ b/net-mgmt/net-snmp/files/patch-al
@@ -1,6 +1,6 @@
---- configure.in~	Sat May  6 01:46:26 2000
-+++ configure.in	Wed May 17 11:09:08 2000
-@@ -1286,6 +1286,26 @@
+--- configure.in.orig	Tue May  7 08:12:10 2002
++++ configure.in	Mon Jun 24 09:38:33 2002
+@@ -1772,6 +1772,26 @@
  AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
  [
  
@@ -26,4 +26,57 @@
 +
  dnl 4.4 compat
  AC_TRY_COMPILE([
- #include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+@@ -2117,29 +2137,29 @@
+ #endif
+ ],swdevt,sw_nblksenabled)
+ 
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_frsize)
+-
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_files)
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_frsize)
++
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_files)
+ 
+ AC_CHECK_STRUCT_FOR([
+ #if HAVE_NLIST_H
diff --git a/net-mgmt/net-snmp53/files/patch-al b/net-mgmt/net-snmp53/files/patch-al
index c2464056b6bc..c50e4967d041 100644
--- a/net-mgmt/net-snmp53/files/patch-al
+++ b/net-mgmt/net-snmp53/files/patch-al
@@ -1,6 +1,6 @@
---- configure.in~	Sat May  6 01:46:26 2000
-+++ configure.in	Wed May 17 11:09:08 2000
-@@ -1286,6 +1286,26 @@
+--- configure.in.orig	Tue May  7 08:12:10 2002
++++ configure.in	Mon Jun 24 09:38:33 2002
+@@ -1772,6 +1772,26 @@
  AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
  [
  
@@ -26,4 +26,57 @@
 +
  dnl 4.4 compat
  AC_TRY_COMPILE([
- #include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+@@ -2117,29 +2137,29 @@
+ #endif
+ ],swdevt,sw_nblksenabled)
+ 
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_frsize)
+-
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_files)
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_frsize)
++
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_files)
+ 
+ AC_CHECK_STRUCT_FOR([
+ #if HAVE_NLIST_H
diff --git a/net/net-snmp/files/patch-al b/net/net-snmp/files/patch-al
index c2464056b6bc..c50e4967d041 100644
--- a/net/net-snmp/files/patch-al
+++ b/net/net-snmp/files/patch-al
@@ -1,6 +1,6 @@
---- configure.in~	Sat May  6 01:46:26 2000
-+++ configure.in	Wed May 17 11:09:08 2000
-@@ -1286,6 +1286,26 @@
+--- configure.in.orig	Tue May  7 08:12:10 2002
++++ configure.in	Mon Jun 24 09:38:33 2002
+@@ -1772,6 +1772,26 @@
  AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
  [
  
@@ -26,4 +26,57 @@
 +
  dnl 4.4 compat
  AC_TRY_COMPILE([
- #include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+@@ -2117,29 +2137,29 @@
+ #endif
+ ],swdevt,sw_nblksenabled)
+ 
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_frsize)
+-
+-AC_CHECK_STRUCT_FOR([
+-#ifdef HAVE_SYS_STAT_H
+-#include <sys/stat.h>
+-#endif
+-#if HAVE_SYS_STATFS_H
+-#include <sys/statfs.h>
+-#endif
+-#if HAVE_SYS_STATVFS_H
+-#include <sys/statvfs.h>
+-#endif
+-],statvfs,f_files)
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_frsize)
++
++dnl AC_CHECK_STRUCT_FOR([
++dnl #ifdef HAVE_SYS_STAT_H
++dnl #include <sys/stat.h>
++dnl #endif
++dnl #if HAVE_SYS_STATFS_H
++dnl #include <sys/statfs.h>
++dnl #endif
++dnl #if HAVE_SYS_STATVFS_H
++dnl #include <sys/statvfs.h>
++dnl #endif
++dnl ],statvfs,f_files)
+ 
+ AC_CHECK_STRUCT_FOR([
+ #if HAVE_NLIST_H
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0