From 14b23de2718dbc6556c8490c4c5604ed36c21ceb Mon Sep 17 00:00:00 2001
From: Andrej Zverev <az@FreeBSD.org>
Date: Thu, 15 Dec 2005 06:42:16 +0000
Subject: - Fix memory leak in BNR (resurrect files/patch-src_libdspam.c from
 Attic   but with totally different content imported from vendor CVS). - Bump
 PORTREVISION.

PR:		ports/90361
Submitted by:	Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> (maintainer)
---
 mail/dspam-devel/Makefile                   |  6 ++++--
 mail/dspam-devel/files/UPDATING             | 10 +++++++---
 mail/dspam-devel/files/dspam-devel.sh.in    |  2 +-
 mail/dspam-devel/files/patch-src_libdspam.c | 25 +++++++++++++++++++++++++
 mail/dspam-devel/pkg-message                |  2 --
 mail/dspam-devel/pkg-plist                  |  2 --
 6 files changed, 37 insertions(+), 10 deletions(-)
 create mode 100644 mail/dspam-devel/files/patch-src_libdspam.c

diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 66748add9268..f6c7e5b2c1a5 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -3,7 +3,8 @@
 # Whom:			Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
 #
 # $FreeBSD$
-# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.9 2005/12/12 01:53:28 itetcu Exp $
+#
+# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.12 2005/12/13 21:09:01 itetcu Exp $
 #
 
 # Note to commiters: If don't commit a maintainer patch and as a result PKGNAME
@@ -13,6 +14,7 @@
 
 PORTNAME=	dspam-devel
 PORTVERSION=	${PORTVER_MAJ}${SNAP_DATE}
+PORTREVISION=	1
 CATEGORIES=	mail
 MASTER_SITES=	http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
 
@@ -40,7 +42,7 @@ DISTFILES=	snapshot-devel.tar.gz
 FETCH_BEFORE_ARGS=	-v -o ${DISTDIR}/${PORTNAME}-${PORTVERSION}.tar.gz
 .endif
 
-_UPD_LINE_NO=	17
+_UPD_LINE_NO=	6
 
 ## debug / log / admin options
 OPTIONS=	DEBUG "Enable debugging logging" on
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index 44d7221ec419..d8be4719455d 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -1,6 +1,3 @@
-$FreeBSD$
-$Tecnik: ports/mail/dspam-devel/files/UPDATING,v 1.6 2005/12/12 01:53:20 itetcu Exp $
-
 This file documents some of the problems you may encounter when
 upgrading dspam port.  I will try my best to minimize these disruptions,
 but sometimes they are unavoidable.
@@ -13,6 +10,13 @@ also the UPGRADING enclosed in the dspam distribution. You can see it by doing
 in the port directory:
 make extract;  more `find . -type f -maxdepth 2 -name UPGRADING`
 
+###########################################################################
+# dspam-devel-3.6.2_1 (2005-12-11 19:18)
+#
+
+Fix memory leak in BNR.
+
+
 ###########################################################################
 # dspam-devel-3.6.2 (2005-12-11 21:34)
 #
diff --git a/mail/dspam-devel/files/dspam-devel.sh.in b/mail/dspam-devel/files/dspam-devel.sh.in
index a94e95abffac..390a040b0fd9 100644
--- a/mail/dspam-devel/files/dspam-devel.sh.in
+++ b/mail/dspam-devel/files/dspam-devel.sh.in
@@ -1,7 +1,7 @@
 #!/bin/sh
 # $FreeBSD$
 # formerly $ FreeBSD: ports/mail/dspam-devel/files/dspam.rc,v 1.2 2005/02/25 03:09:26 leeym Exp $
-# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.2 2005/12/11 21:57:45 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/files/dspam-devel.sh.in,v 1.3 2005/12/13 21:09:37 itetcu Exp $
 
 # PROVIDE: dspam
 # REQUIRE: DAEMON %%MYSQL%% %%PGSQL%% %%CLAMD%%
diff --git a/mail/dspam-devel/files/patch-src_libdspam.c b/mail/dspam-devel/files/patch-src_libdspam.c
new file mode 100644
index 000000000000..2e9c78dbb6bd
--- /dev/null
+++ b/mail/dspam-devel/files/patch-src_libdspam.c
@@ -0,0 +1,25 @@
+Index: dspam/src/libdspam.c
+===================================================================
+RCS file: /usr/local/cvsroot/dspam/src/libdspam.c,v
+retrieving revision 1.144
+retrieving revision 1.145
+diff -u -r1.144 -r1.145
+--- src/libdspam.c	24 Nov 2005 14:09:12 -0000	1.144
++++ src/libdspam.c	13 Dec 2005 16:59:45 -0000	1.145
+@@ -1,4 +1,4 @@
+-/* $Id: libdspam.c,v 1.144 2005/11/24 14:09:12 jonz Exp $ */
++/* $Id: libdspam.c,v 1.145 2005/12/13 16:59:45 jonz Exp $ */
+ 
+ /*
+  DSPAM
+@@ -892,7 +892,9 @@
+   /* Apply Bayesian Noise Reduction */
+   if (CTX->flags & DSF_NOISE)
+   {
+-    _ds_apply_bnr(CTX, diction);
++    ds_diction_t p = _ds_apply_bnr(CTX, diction);
++    if (p) 
++      ds_diction_destroy(p);
+   }
+ 
+   if (CTX->flags & DSF_WHITELIST)
diff --git a/mail/dspam-devel/pkg-message b/mail/dspam-devel/pkg-message
index 0ceb924bd5e6..d3b51389a78a 100644
--- a/mail/dspam-devel/pkg-message
+++ b/mail/dspam-devel/pkg-message
@@ -1,5 +1,3 @@
-%%FreeBSD%%$FreeBSD$
-%%Tecnik%%$Tecnik: ports/mail/dspam-devel/pkg-message,v 1.3 2005/12/11 20:59:38 itetcu Exp $
 -------------------------------------------------------------------------------
  Reporting problems, asking questions:
  - FreeBSD specific port-related problems/questions/paches: maintainer
diff --git a/mail/dspam-devel/pkg-plist b/mail/dspam-devel/pkg-plist
index f6cd548670c3..dbf1d74a5842 100644
--- a/mail/dspam-devel/pkg-plist
+++ b/mail/dspam-devel/pkg-plist
@@ -1,5 +1,3 @@
-@comment $FreeBSD$
-@comment $Tecnik: ports/mail/dspam-devel/pkg-plist,v 1.2 2005/12/11 20:46:46 itetcu Exp $
 %%HASH%%bin/cssstat
 %%HASH%%bin/csscompress
 %%HASH%%bin/cssclean
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0