From 108207934718fe18a2c437e634d2b856da536b4c Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Sun, 27 Nov 2011 09:42:55 +0000
Subject: - Update to version 0.1.3

PR:		162830
Submitted by:	Ports Fury
Feature safe:	yes
---
 net/netmap/Makefile                          |  7 ++++---
 net/netmap/distinfo                          |  4 ++--
 net/netmap/files/patch-belgolib::dirs.h      |  9 ---------
 net/netmap/files/patch-belgolib::dirs_core.c | 10 ----------
 net/netmap/files/patch-belgolib::files.c     | 18 +++++-------------
 net/netmap/files/patch-belgolib::search.c    | 11 -----------
 net/netmap/files/patch-makelist::Makefile    |  6 +++---
 net/netmap/files/patch-netmap::Makefile      |  6 +++---
 net/netmap/files/patch-netmap::lookup.c      | 22 ++--------------------
 net/netmap/files/patch-netmap::misc.h        | 28 ----------------------------
 net/netmap/files/patch-netmap::netmap.c      | 20 --------------------
 net/netmap/pkg-plist                         |  2 --
 12 files changed, 19 insertions(+), 124 deletions(-)
 delete mode 100644 net/netmap/files/patch-belgolib::dirs_core.c
 delete mode 100644 net/netmap/files/patch-belgolib::search.c
 delete mode 100644 net/netmap/files/patch-netmap::misc.h
 delete mode 100644 net/netmap/files/patch-netmap::netmap.c
 delete mode 100644 net/netmap/pkg-plist

diff --git a/net/netmap/Makefile b/net/netmap/Makefile
index d1833802c93b..1e0027cfbb04 100644
--- a/net/netmap/Makefile
+++ b/net/netmap/Makefile
@@ -7,10 +7,9 @@
 #
 
 PORTNAME=	netmap
-PORTVERSION=	0.1.2b
-PORTREVISION=	5
+PORTVERSION=	0.1.3
 CATEGORIES=	net
-MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/NetMap%200.1.2
+MASTER_SITES=	SF/${PORTNAME}/${PORTNAME}/NetMap%20${PORTVERSION}
 
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Make a graphical representation of the surounding network
@@ -19,6 +18,8 @@ RUN_DEPENDS=	dotty:${PORTSDIR}/graphics/graphviz
 
 USE_GMAKE=	yes
 
+PLIST_FILES=	bin/makelist bin/netmap
+
 do-install:
 	${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
 	${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
diff --git a/net/netmap/distinfo b/net/netmap/distinfo
index 87212ff06b24..825115316047 100644
--- a/net/netmap/distinfo
+++ b/net/netmap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netmap-0.1.2b.tar.gz) = 06327965bd586a8c243999ee748dba425bd1da6a37e8b6af11476a6563cbfbdc
-SIZE (netmap-0.1.2b.tar.gz) = 33640
+SHA256 (netmap-0.1.3.tar.gz) = c2d8e7289e5955ccb1584f839bf8bb527bf6682564f6ed03a06fc1eee5f1c9b8
+SIZE (netmap-0.1.3.tar.gz) = 58345
diff --git a/net/netmap/files/patch-belgolib::dirs.h b/net/netmap/files/patch-belgolib::dirs.h
index 27542fb44f9c..4d912a46559c 100644
--- a/net/netmap/files/patch-belgolib::dirs.h
+++ b/net/netmap/files/patch-belgolib::dirs.h
@@ -8,12 +8,3 @@
  
  #ifndef __make_dep__
  #include <string>
-@@ -91,7 +92,7 @@
- {
-     list<T*> result=ld1;
- 
--    for(list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
-+    for(typename list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
- 	result.push_back(*i);
- 
-     return result;
diff --git a/net/netmap/files/patch-belgolib::dirs_core.c b/net/netmap/files/patch-belgolib::dirs_core.c
deleted file mode 100644
index 425d097f0297..000000000000
--- a/net/netmap/files/patch-belgolib::dirs_core.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- belgolib/dirs_core.c.orig	Sun Dec 15 15:02:19 2002
-+++ belgolib/dirs_core.c	Sun Dec 15 15:02:25 2002
-@@ -1,6 +1,6 @@
- #include "dirs_core.h"
- 
--Oinfo::Oinfo(const string& fname, int fmode=0) 
-+Oinfo::Oinfo(const string& fname, int fmode) 
- {
-     stat_info = new struct stat;
- 
diff --git a/net/netmap/files/patch-belgolib::files.c b/net/netmap/files/patch-belgolib::files.c
index c5aab8d1dcc4..30c2737ad31b 100644
--- a/net/netmap/files/patch-belgolib::files.c
+++ b/net/netmap/files/patch-belgolib::files.c
@@ -1,23 +1,15 @@
---- belgolib/files.c.orig	Sun Dec 15 14:54:27 2002
-+++ belgolib/files.c	Sun Dec 15 14:54:27 2002
-@@ -1,6 +1,7 @@
- #include <errno.h>
- #include <stdio.h>
- #include <assert.h>
-+#include <iostream>
- 
- #include "files.h"
- #include "debug.h"
-@@ -16,7 +17,7 @@
+--- belgolib/files.c.orig	2010-01-06 08:00:52.000000000 +0900
++++ belgolib/files.c	2011-11-23 22:22:36.000000000 +0900
+@@ -17,7 +17,7 @@
  
  Infile::Infile() : ifstream() { }
  
 -Infile::Infile(const string& file_name, int mode, bool fatal)
 +Infile::Infile(const string& file_name, ios::openmode mode, bool fatal)
-     : ifstream(file_name.c_str(), mode)
+     : ifstream(file_name.c_str(), (std::_Ios_Openmode)mode)
  {
  
-@@ -38,7 +39,7 @@
+@@ -39,7 +39,7 @@
  }
  
  
diff --git a/net/netmap/files/patch-belgolib::search.c b/net/netmap/files/patch-belgolib::search.c
deleted file mode 100644
index a70795fa237d..000000000000
--- a/net/netmap/files/patch-belgolib::search.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- belgolib/search.c.orig	Sun Dec 15 14:54:27 2002
-+++ belgolib/search.c	Sun Dec 15 14:54:27 2002
-@@ -5,7 +5,7 @@
- // SearchPath members
- 
- 
--void SearchPath::add_dir(const list<string>& dlist, int depth = 0) 
-+void SearchPath::add_dir(const list<string>& dlist, int depth) 
- {
-     for(CSiter diter = dlist.begin(); diter != dlist.end(); diter++) 
- 	add_dir( *diter, depth);    
diff --git a/net/netmap/files/patch-makelist::Makefile b/net/netmap/files/patch-makelist::Makefile
index 7d89da1b7c85..d6d4b6d7cb79 100644
--- a/net/netmap/files/patch-makelist::Makefile
+++ b/net/netmap/files/patch-makelist::Makefile
@@ -1,10 +1,10 @@
---- makelist/Makefile.orig	Fri Jun  7 00:13:32 2002
-+++ makelist/Makefile	Fri Jun  7 00:13:40 2002
+--- makelist/Makefile.orig	2010-01-06 07:59:38.000000000 +0900
++++ makelist/Makefile	2011-11-23 22:25:58.000000000 +0900
 @@ -1,8 +1,7 @@
  CFILES   = makelist.c args.c config.c
  OFILES   = $(CFILES:.c=.o)
  
--CFLAGS = -O -Wall 
+-CFLAGS = -O -Wall -Wno-deprecated
 -CC = g++
 +CC = ${CXX}
  
diff --git a/net/netmap/files/patch-netmap::Makefile b/net/netmap/files/patch-netmap::Makefile
index 5b15ca1dfa62..c966683084d2 100644
--- a/net/netmap/files/patch-netmap::Makefile
+++ b/net/netmap/files/patch-netmap::Makefile
@@ -1,10 +1,10 @@
---- netmap/Makefile.orig	Fri Jun  7 00:12:40 2002
-+++ netmap/Makefile	Fri Jun  7 00:12:56 2002
+--- netmap/Makefile.orig	2010-01-06 07:59:38.000000000 +0900
++++ netmap/Makefile	2011-11-23 22:27:31.000000000 +0900
 @@ -1,8 +1,7 @@
  CFILES   = misc.c hostclass.c netmap.c drawmap.c config.c args.c lookup.c
  OFILES   = $(CFILES:.c=.o)
  
--CFLAGS = -O -Wall  
+-CFLAGS = -O -Wall -Wno-deprecated
 -CC = g++
 +CC = ${CXX}
  
diff --git a/net/netmap/files/patch-netmap::lookup.c b/net/netmap/files/patch-netmap::lookup.c
index c756665f00ce..5bfc31c556d0 100644
--- a/net/netmap/files/patch-netmap::lookup.c
+++ b/net/netmap/files/patch-netmap::lookup.c
@@ -1,5 +1,5 @@
---- netmap/lookup.c.orig	Sun Dec 15 14:54:26 2002
-+++ netmap/lookup.c	Sun Dec 15 14:54:26 2002
+--- netmap/lookup.c.orig	2010-01-06 07:59:38.000000000 +0900
++++ netmap/lookup.c	2011-11-23 22:32:15.000000000 +0900
 @@ -1,6 +1,8 @@
  #include <strstream>
  #include <iostream>
@@ -9,21 +9,3 @@
  #include <netdb.h> 	//hostent def
  
  //from belgolib
-@@ -83,7 +85,7 @@
-     if(verbose_lvl)
- 	cout << indent(2) << "Reading " << fname << endl;
-     
--    Infile cfile(fname, ios::bin | ios::in);
-+    Infile cfile(fname, ios::binary | ios::in);
- 
-     while(cfile && !cfile.eof()) {
- 	HostRec hr;
-@@ -229,7 +231,7 @@
- 
- void LookUp::read_failedip(const string& fname) 
- {
--    Infile cfile(fname, ios::bin | ios::in);
-+    Infile cfile(fname, ios::binary | ios::in);
- 
-     while(cfile && !cfile.eof()) {
- 	string ip;
diff --git a/net/netmap/files/patch-netmap::misc.h b/net/netmap/files/patch-netmap::misc.h
deleted file mode 100644
index 4ea51bf3124e..000000000000
--- a/net/netmap/files/patch-netmap::misc.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- netmap/misc.h.orig	Sun Dec 15 14:54:26 2002
-+++ netmap/misc.h	Sun Dec 15 14:54:26 2002
-@@ -6,6 +6,7 @@
- #include <iostream>
- 
- #include <list>
-+using namespace std;
- 
- 
- string indent(unsigned);
-@@ -21,7 +22,7 @@
- template <class T>
- bool contains(list<T>& l, const T& t) 
- {
--    for(list<T>::iterator li = l.begin(); li != l.end(); li++)
-+    for(typename list<T>::iterator li = l.begin(); li != l.end(); li++)
- 	if((*li) == t)
- 	    return true;
-     return false;
-@@ -31,7 +32,7 @@
- list<T> intersect(list<T>& l1, list<T>& l2) 
- {
-     list<T> result;
--    for(list<T>::iterator li = l1.begin(); li != l1.end(); li++)
-+    for(typename list<T>::iterator li = l1.begin(); li != l1.end(); li++)
- 	if(contains(l2, *li))
- 	    result.push_back(*li);
- 
diff --git a/net/netmap/files/patch-netmap::netmap.c b/net/netmap/files/patch-netmap::netmap.c
deleted file mode 100644
index 9cb6b449815f..000000000000
--- a/net/netmap/files/patch-netmap::netmap.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- netmap/netmap.c.orig	Sun Dec 15 14:54:26 2002
-+++ netmap/netmap.c	Sun Dec 15 14:54:26 2002
-@@ -32,7 +32,7 @@
- 
- int count_invalid_hosts(const string& fname) 
- {
--    Infile inf(fname, ios::bin | ios::in);
-+    Infile inf(fname, ios::binary | ios::in);
- 
-     int invalid_hosts = 0;
-     int invalid_left = 0;
-@@ -60,7 +60,7 @@
-     const int num_invalid_hosts =
- 	(keep_reading?count_invalid_hosts(fname):0);
-     
--    Infile inf(fname, ios::bin | ios::in);
-+    Infile inf(fname, ios::binary | ios::in);
- 
-     int mark_first = 1;
-     string prev_addr = inv_ip;
diff --git a/net/netmap/pkg-plist b/net/netmap/pkg-plist
deleted file mode 100644
index ec1257e098c6..000000000000
--- a/net/netmap/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/makelist
-bin/netmap
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0