From 098b40f956e66d19345c6296ebd25934701e2609 Mon Sep 17 00:00:00 2001
From: Rene Ladan <rene@FreeBSD.org>
Date: Mon, 23 Nov 2015 21:10:50 +0000
Subject: A Django reusable app providing the overextends template tag, a
 drop-in replacement for Django's extends tag, which allows you to use
 circular template inheritance.

The primary use-case for overextends is to simultaneously override and extend
templates from other reusable apps, in your own Django project.

WWW: https://github.com/stephenmcd/django-overextends
---
 www/Makefile                        |  1 +
 www/py-django-overextends/Makefile  | 22 ++++++++++++++++++++++
 www/py-django-overextends/distinfo  |  2 ++
 www/py-django-overextends/pkg-descr |  8 ++++++++
 4 files changed, 33 insertions(+)
 create mode 100644 www/py-django-overextends/Makefile
 create mode 100644 www/py-django-overextends/distinfo
 create mode 100644 www/py-django-overextends/pkg-descr

diff --git a/www/Makefile b/www/Makefile
index c339f6f91683..e1eb632c4a99 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1546,6 +1546,7 @@
     SUBDIR += py-django-mezzanine-grappelli
     SUBDIR += py-django-mptt
     SUBDIR += py-django-openid-auth
+    SUBDIR += py-django-overextends
     SUBDIR += py-django-photologue
     SUBDIR += py-django-picklefield
     SUBDIR += py-django-pipeline
diff --git a/www/py-django-overextends/Makefile b/www/py-django-overextends/Makefile
new file mode 100644
index 000000000000..31bf9cdade81
--- /dev/null
+++ b/www/py-django-overextends/Makefile
@@ -0,0 +1,22 @@
+# Created by: René Ladan <rene@freebsd.org>
+# $FreeBSD$
+
+PORTNAME=	django-overextends
+PORTVERSION=	0.4.0
+CATEGORIES=	www python
+MASTER_SITES=	CHEESESHOP
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	rene@freebsd.org
+COMMENT=	Django reusable app enabling circular template inheritance
+
+LICENSE=	BSD2CLAUSE
+
+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}django>=1.7:${PORTSDIR}/www/py-django
+
+NO_ARCH=	yes
+
+USES=		python
+USE_PYTHON=	autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-django-overextends/distinfo b/www/py-django-overextends/distinfo
new file mode 100644
index 000000000000..47cdf1333ea5
--- /dev/null
+++ b/www/py-django-overextends/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-overextends-0.4.0.tar.gz) = 63eed9add4282bc932d76c69abad2c20436d0984b62040fbdffd5872eadb7da6
+SIZE (django-overextends-0.4.0.tar.gz) = 7759
diff --git a/www/py-django-overextends/pkg-descr b/www/py-django-overextends/pkg-descr
new file mode 100644
index 000000000000..6b538b53ccd9
--- /dev/null
+++ b/www/py-django-overextends/pkg-descr
@@ -0,0 +1,8 @@
+A Django reusable app providing the overextends template tag, a drop-in
+replacement for Django's extends tag, which allows you to use circular
+template inheritance.
+
+The primary use-case for overextends is to simultaneously override and extend
+templates from other reusable apps, in your own Django project.
+
+WWW: https://github.com/stephenmcd/django-overextends
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0