From 09872fbe191c8faee9cb5c280f2a531778bad7f7 Mon Sep 17 00:00:00 2001
From: Andrew Pantyukhin <sat@FreeBSD.org>
Date: Thu, 30 Aug 2007 11:55:43 +0000
Subject: Add port devel/gettext-msghack:

Msghack can be used to alter gettext .po files in ways no sane mind
would think about. It is a reimplementation of the original msghack
in Python.

Author: Trond Eivind Glomsroed <teg@redhat.com>
---
 devel/Makefile                  |  1 +
 devel/gettext-msghack/Makefile  | 30 ++++++++++++++++++++++++++++++
 devel/gettext-msghack/distinfo  |  3 +++
 devel/gettext-msghack/pkg-descr |  5 +++++
 4 files changed, 39 insertions(+)
 create mode 100644 devel/gettext-msghack/Makefile
 create mode 100644 devel/gettext-msghack/distinfo
 create mode 100644 devel/gettext-msghack/pkg-descr

diff --git a/devel/Makefile b/devel/Makefile
index 22c3d67caa03..a3b954234d0e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -374,6 +374,7 @@
     SUBDIR += genproto
     SUBDIR += gettext
     SUBDIR += gettext-lint
+    SUBDIR += gettext-msghack
     SUBDIR += getxml
     SUBDIR += gflags
     SUBDIR += gindent
diff --git a/devel/gettext-msghack/Makefile b/devel/gettext-msghack/Makefile
new file mode 100644
index 000000000000..ee28bf0c9639
--- /dev/null
+++ b/devel/gettext-msghack/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for:	gettext-msghack
+# Date created:		30 August 2007
+# Whom:			Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	msghack
+PORTVERSION=	0.2
+CATEGORIES=	devel
+MASTER_SITES=	CENKES
+PKGNAMEPREFIX=	gettext-
+# Bundled in fedora gettext srpm
+
+MAINTAINER=	infofarmer@FreeBSD.org
+COMMENT=	Alter gettext po files in special ways
+
+NO_BUILD=	yes
+USE_BZIP2=	yes
+USE_PYTHON=	yes
+PLIST_FILES=	bin/${PORTNAME}
+
+post-patch:
+	@${REINPLACE_CMD} -e '1s|/usr/bin/python|${PYTHON_CMD}|'\
+		${WRKSRC}/${PORTNAME}.py
+
+do-install:
+	@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/gettext-msghack/distinfo b/devel/gettext-msghack/distinfo
new file mode 100644
index 000000000000..f9a556250f92
--- /dev/null
+++ b/devel/gettext-msghack/distinfo
@@ -0,0 +1,3 @@
+MD5 (msghack-0.2.tar.bz2) = 520f87fe064183b4adc3bdbb3c2f481a
+SHA256 (msghack-0.2.tar.bz2) = c2b3ab088dd3e909649bee7840603d232ede6447176ed4e5d41df33b30a53664
+SIZE (msghack-0.2.tar.bz2) = 3149
diff --git a/devel/gettext-msghack/pkg-descr b/devel/gettext-msghack/pkg-descr
new file mode 100644
index 000000000000..b75f33c6f640
--- /dev/null
+++ b/devel/gettext-msghack/pkg-descr
@@ -0,0 +1,5 @@
+Msghack can be used to alter gettext .po files in ways no sane mind
+would think about. It is a reimplementation of the original msghack
+in Python.
+
+Author: Trond Eivind Glomsroed <teg@redhat.com>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0