From 0703fa8995d8954e8f9a44e36c889c4cd1fb8be0 Mon Sep 17 00:00:00 2001
From: Sergey Matveychuk <sem@FreeBSD.org>
Date: Tue, 21 Aug 2007 12:50:57 +0000
Subject: - Roll back to a previous version. The last one complete broken. -
 PORTEPOCH bump.

---
 mail/zmailer/Makefile                              |  5 ++-
 mail/zmailer/distinfo                              |  6 ++--
 mail/zmailer/files/patch-EAI_NODATA                | 37 ++++++++++++++++++++++
 mail/zmailer/files/patch-aa                        | 34 ++++++++++++++++++++
 mail/zmailer/files/patch-ab                        | 10 ++++++
 mail/zmailer/files/patch-proto::post-install.sh.in | 11 +++++++
 mail/zmailer/files/patch-smtpserver-smtpetrn.c     | 11 +++++++
 mail/zmailer/files/patch-transports-smtp-smtp.h    | 12 +++++++
 mail/zmailer/pkg-message                           |  3 ++
 mail/zmailer/pkg-plist                             | 11 +++++--
 10 files changed, 132 insertions(+), 8 deletions(-)
 create mode 100644 mail/zmailer/files/patch-EAI_NODATA
 create mode 100644 mail/zmailer/files/patch-aa
 create mode 100644 mail/zmailer/files/patch-ab
 create mode 100644 mail/zmailer/files/patch-proto::post-install.sh.in
 create mode 100644 mail/zmailer/files/patch-smtpserver-smtpetrn.c
 create mode 100644 mail/zmailer/files/patch-transports-smtp-smtp.h
 create mode 100644 mail/zmailer/pkg-message

diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index 8ad7a694ff86..a9ee1659fb7b 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -6,7 +6,8 @@
 #
 
 PORTNAME=	zmailer
-PORTVERSION=	2.99.57
+PORTVERSION=	2.99.56
+PORTEPOCH=	1
 CATEGORIES=	mail
 MASTER_SITES=	ftp://ftp.funet.fi/pub/unix/mail/zmailer/src/
 
@@ -24,8 +25,6 @@ CONFIGURE_ARGS=	--with-openssl
 CONFIGURE_ARGS=	--without-openssl
 .endif
 
-IGNORE=		hangs after mail to: command
-
 .include <bsd.port.pre.mk>
 
 CONFIGURE_ARGS+=--prefix=${PREFIX}/ \
diff --git a/mail/zmailer/distinfo b/mail/zmailer/distinfo
index 0c13b3819b05..b6d752753f03 100644
--- a/mail/zmailer/distinfo
+++ b/mail/zmailer/distinfo
@@ -1,3 +1,3 @@
-MD5 (zmailer-2.99.57.tar.gz) = abe451575234ac5ce79d9b950b150986
-SHA256 (zmailer-2.99.57.tar.gz) = 74b878138d82c765174c44250a7789b15c70a1d0fc39bddd096cd4147ed5a115
-SIZE (zmailer-2.99.57.tar.gz) = 5521100
+MD5 (zmailer-2.99.56.tar.gz) = c94cc0c2e2427a210a046a02ac4c2d50
+SHA256 (zmailer-2.99.56.tar.gz) = 7a5e6c051fc9c9bdf9774fe9ce11871105d20f569e61bdc8da222a1ff587678d
+SIZE (zmailer-2.99.56.tar.gz) = 5926859
diff --git a/mail/zmailer/files/patch-EAI_NODATA b/mail/zmailer/files/patch-EAI_NODATA
new file mode 100644
index 000000000000..b42624c6e7fd
--- /dev/null
+++ b/mail/zmailer/files/patch-EAI_NODATA
@@ -0,0 +1,37 @@
+--- smtpserver/mxverify.c.orig	Fri Apr 16 15:45:46 2004
++++ smtpserver/mxverify.c	Fri Apr 16 15:46:38 2004
+@@ -607,7 +607,6 @@
+ 	if (retmode == '+') {
+ 	  if (rc == -EX_NOHOST      ||
+ 	      rc == -EX_UNAVAILABLE ||
+-	      rc == EAI_NODATA      ||
+ 	      rc == EAI_NONAME)
+ 	    return -2; /* Definitely hard errors */
+ 	  if (rc == 2)
+--- transports/smtp/smtp.c.orig	Fri Apr 16 15:48:44 2004
++++ transports/smtp/smtp.c	Fri Apr 16 15:54:18 2004
+@@ -2912,6 +2912,7 @@
+ 		return EX_DEFERALL;
+ 	      }
+ 
++#if 0 /* FreeBSD 5.x doesn't have it */
+ 	      if ( r == EAI_NODATA ) {
+ 		sprintf(SS->remotemsg,"smtp; 500 (getaddrinfo<%.200s>: No data)",host);
+ 		time(&endtime);
+@@ -2925,6 +2926,7 @@
+ 		  return EX_DEFERALL;
+ 		return EX_UNAVAILABLE;
+ 	      }
++#endif
+ 
+ 	      r = EX_UNAVAILABLE; /* This gives instant rejection */
+ 	      if (rc == EX_TEMPFAIL) r = rc;
+@@ -2944,7 +2946,7 @@
+ 		  if (r != EX_TEMPFAIL)
+ 		    r = EX_NOHOST;
+ #endif
+-		} else if (gai_err == EAI_NONAME || gai_err == EAI_NODATA) {
++		} else if (gai_err == EAI_NONAME)  {
+ 		  sprintf(SS->remotemsg,
+ 			  "smtp; 500 (nameserver data inconsistency. No MX, no address: '%.200s' (%s))",
+ 			  host, gai_err == EAI_NONAME ? "NONAME" : "NODATA");
diff --git a/mail/zmailer/files/patch-aa b/mail/zmailer/files/patch-aa
new file mode 100644
index 000000000000..7a83abb03cf9
--- /dev/null
+++ b/mail/zmailer/files/patch-aa
@@ -0,0 +1,34 @@
+--- configure.orig	Fri Dec 26 10:29:15 2003
++++ configure	Fri Dec 26 10:33:26 2003
+@@ -280,6 +280,7 @@
+ # Factoring default headers for most tests.
+ ac_includes_default="\
+ #include <stdio.h>
++#include <sys/param.h>
+ #if HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+@@ -20317,7 +20318,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
+ 
+-#include <sys/types.h>
++#include <sys/param.h>
+ #include <sys/mount.h>
+ #include <sys/fs_types.h>
+ int
+@@ -20493,6 +20494,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h.  */
++#include <sys/param.h>
+ #include <sys/mount.h>
+ 
+ _ACEOF
+@@ -20539,5 +20541,6 @@
+ /* end confdefs.h.  */
+ 
+ #include <sys/fs_types.h>
++#include <sys/param.h>
+ #include <sys/mount.h>
+ _ACEOF
diff --git a/mail/zmailer/files/patch-ab b/mail/zmailer/files/patch-ab
new file mode 100644
index 000000000000..f167d88b90db
--- /dev/null
+++ b/mail/zmailer/files/patch-ab
@@ -0,0 +1,10 @@
+--- transports/smtp/getmxrr.c.orig	Mon Jun 23 12:04:35 2003
++++ transports/smtp/getmxrr.c	Fri Dec 26 11:30:58 2003
+@@ -416,7 +416,6 @@
+ 	      break;
+ 	    case EAI_NONAME:
+ 	    case EAI_FAIL:
+-	    case EAI_NODATA:
+ 	    case EAI_SERVICE:
+ 	    default:
+ 	      break;
diff --git a/mail/zmailer/files/patch-proto::post-install.sh.in b/mail/zmailer/files/patch-proto::post-install.sh.in
new file mode 100644
index 000000000000..c352a1a9bbbd
--- /dev/null
+++ b/mail/zmailer/files/patch-proto::post-install.sh.in
@@ -0,0 +1,11 @@
+--- proto/post-install.sh.in.orig	Fri Apr 16 12:45:45 2004
++++ proto/post-install.sh.in	Fri Apr 16 12:46:00 2004
+@@ -373,7 +373,7 @@
+ ", $POSTOFFICE);
+ 
+ if (! -d "$POSTOFFICE/.") {
+-    mymysystem("$MKDIR -p $POSTOFFICE");
++    mysystem("$MKDIR -p $POSTOFFICE");
+     
+ }
+ mysystem("chmod 2755 $POSTOFFICE/.");
diff --git a/mail/zmailer/files/patch-smtpserver-smtpetrn.c b/mail/zmailer/files/patch-smtpserver-smtpetrn.c
new file mode 100644
index 000000000000..e81d603f331f
--- /dev/null
+++ b/mail/zmailer/files/patch-smtpserver-smtpetrn.c
@@ -0,0 +1,11 @@
+--- smtpserver/smtpetrn.c.orig	Sun Sep 24 14:05:20 2006
++++ smtpserver/smtpetrn.c	Sun Sep 24 14:06:45 2006
+@@ -21,6 +21,8 @@
+ 
+ #ifndef HAVE_OPENSSL
+ #include "md5.h"
++#else
++#include <openssl/md5.h>
+ #endif /* --HAVE_OPENSSL */
+ 
+ static int local_etrn(SS, name, cp, silence)
diff --git a/mail/zmailer/files/patch-transports-smtp-smtp.h b/mail/zmailer/files/patch-transports-smtp-smtp.h
new file mode 100644
index 000000000000..53b9a640e87d
--- /dev/null
+++ b/mail/zmailer/files/patch-transports-smtp-smtp.h
@@ -0,0 +1,12 @@
+--- transports/smtp/smtp.h.orig	Sun Sep 24 14:10:22 2006
++++ transports/smtp/smtp.h	Sun Sep 24 14:10:56 2006
+@@ -69,6 +69,9 @@
+ #include <netinet/tcp.h>
+ #endif
+ 
++#include <sys/types.h>
++#include <openssl/md5.h>
++
+ #ifndef	NFDBITS
+ /*
+  * This stuff taken from the 4.3bsd /usr/include/sys/types.h, but on the
diff --git a/mail/zmailer/pkg-message b/mail/zmailer/pkg-message
new file mode 100644
index 000000000000..e76dbee0ae56
--- /dev/null
+++ b/mail/zmailer/pkg-message
@@ -0,0 +1,3 @@
+***
+*** Adjust mailer.conf(5) as appropriate.
+***
diff --git a/mail/zmailer/pkg-plist b/mail/zmailer/pkg-plist
index bbf648010900..ccc2d688bcc5 100644
--- a/mail/zmailer/pkg-plist
+++ b/mail/zmailer/pkg-plist
@@ -53,6 +53,7 @@ etc/zmailer/forms/proto/loopexceeded.md5
 etc/zmailer/forms/proto/nonewsgroup.md5
 etc/zmailer/forms/proto/norealname.md5
 etc/zmailer/forms/proto/norecipients.md5
+etc/zmailer/forms/proto/nosuchuser.md5
 etc/zmailer/forms/proto/unresolvable.md5
 etc/zmailer/forms/proto/vms-in-pros.md5
 etc/zmailer/forms/proto/wrongname.md5
@@ -70,6 +71,7 @@ etc/zmailer/forms/loopexceeded
 etc/zmailer/forms/nonewsgroup
 etc/zmailer/forms/norealname
 etc/zmailer/forms/norecipients
+etc/zmailer/forms/nosuchuser
 etc/zmailer/forms/unresolvable
 etc/zmailer/forms/vms-in-pros
 etc/zmailer/forms/wrongname
@@ -89,6 +91,7 @@ etc/zmailer/cf/proto/p-uucp.cf.md5
 etc/zmailer/cf/proto/p-usenet.cf.md5
 etc/zmailer/cf/proto/p-smtp.cf.md5
 etc/zmailer/cf/proto/p-routes.cf.md5
+etc/zmailer/cf/proto/p-ldap.cf.md5
 etc/zmailer/cf/proto/p-iproutes.cf.md5
 etc/zmailer/cf/proto/p-ean.cf.md5
 etc/zmailer/cf/proto/p-bitnet.cf.md5
@@ -113,6 +116,7 @@ etc/zmailer/cf/proto/UTGPU.cf.md5
 etc/zmailer/cf/proto/UTAI.cf.md5
 etc/zmailer/cf/proto/TELE-FI.cf.md5
 etc/zmailer/cf/proto/SMTP.cf.md5
+etc/zmailer/cf/proto/tryme.cf.md5
 etc/zmailer/cf/SMTP+UUCP.cf
 etc/zmailer/cf/trusted.cf
 etc/zmailer/cf/standard.cf
@@ -123,6 +127,7 @@ etc/zmailer/cf/p-uucp.cf
 etc/zmailer/cf/p-usenet.cf
 etc/zmailer/cf/p-smtp.cf
 etc/zmailer/cf/p-routes.cf
+etc/zmailer/cf/p-ldap.cf
 etc/zmailer/cf/p-iproutes.cf
 etc/zmailer/cf/p-ean.cf
 etc/zmailer/cf/p-bitnet.cf
@@ -147,6 +152,7 @@ etc/zmailer/cf/UTGPU.cf
 etc/zmailer/cf/UTAI.cf
 etc/zmailer/cf/TELE-FI.cf
 etc/zmailer/cf/SMTP.cf
+etc/zmailer/cf/tryme.cf
 etc/zmailer/scheduler.conf
 etc/zmailer/sm.conf
 etc/zmailer/smtpserver.conf
@@ -178,6 +184,7 @@ etc/zmailer/forms/proto/loopexceeded
 etc/zmailer/forms/proto/nonewsgroup
 etc/zmailer/forms/proto/norealname
 etc/zmailer/forms/proto/norecipients
+etc/zmailer/forms/proto/nosuchuser
 etc/zmailer/forms/proto/unresolvable
 etc/zmailer/forms/proto/vms-in-pros
 etc/zmailer/forms/proto/wrongname
@@ -193,7 +200,6 @@ etc/zmailer/guides/smtpauth-login-pam-support
 etc/zmailer/guides/smtp-policy
 etc/zmailer/guides/smtp-msa-mode
 etc/zmailer/guides/smtp-etrn
-etc/zmailer/guides/smtpserver-spf
 etc/zmailer/guides/scheduler-ta-protocol
 etc/zmailer/guides/relations
 etc/zmailer/guides/procmail
@@ -223,6 +229,7 @@ etc/zmailer/cf/proto/p-uucp.cf
 etc/zmailer/cf/proto/p-usenet.cf
 etc/zmailer/cf/proto/p-smtp.cf
 etc/zmailer/cf/proto/p-routes.cf
+etc/zmailer/cf/proto/p-ldap.cf
 etc/zmailer/cf/proto/p-iproutes.cf
 etc/zmailer/cf/proto/p-ean.cf
 etc/zmailer/cf/proto/p-bitnet.cf
@@ -247,6 +254,7 @@ etc/zmailer/cf/proto/UTGPU.cf
 etc/zmailer/cf/proto/UTAI.cf
 etc/zmailer/cf/proto/TELE-FI.cf
 etc/zmailer/cf/proto/SMTP.cf
+etc/zmailer/cf/proto/tryme.cf
 etc/zmailer/vacation.msg
 etc/zmailer/mail.conf.sample
 @exec mkdir -p %D/etc/zmailer/lists
@@ -299,7 +307,6 @@ sbin/smtpserver-log-parser.pl
 sbin/vacation.exe
 sbin/vacation.sh
 sbin/zmailer
-sbin/zrfilter
 sbin/ta/bitbucket
 sbin/ta/errormail
 sbin/ta/expirer
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0