From 03b1cffca762aa2a121124730b69506209007236 Mon Sep 17 00:00:00 2001
From: Matthias Andree <mandree@FreeBSD.org>
Date: Mon, 5 Aug 2013 20:37:35 +0000
Subject: Link lua .so + program with pthread to prevent hangs in extensions
 that use pthreads.

Bump PORTREVISION to pull this in.

PR:		ports/181052
Submitted by:	Vitaly Magerya <vmagerya@gmail.com>
Approved by:	mandree@ on behalf of lua@
---
 lang/lua/Makefile                 |  4 ++--
 lang/lua/files/patch-src-Makefile | 12 ++++++++----
 lang/lua52/Makefile               |  3 ++-
 3 files changed, 12 insertions(+), 7 deletions(-)

diff --git a/lang/lua/Makefile b/lang/lua/Makefile
index 709eaeb8862e..c1efaf408691 100644
--- a/lang/lua/Makefile
+++ b/lang/lua/Makefile
@@ -3,7 +3,7 @@
 
 PORTNAME=	lua
 PORTVERSION=	5.1.5
-PORTREVISION=	5
+PORTREVISION=	6
 CATEGORIES=	lang
 MASTER_SITES=	http://www.lua.org/ftp/ \
 		ftp://ftp.ntua.gr/pub/lang/lua/ \
@@ -33,7 +33,7 @@ MAKE_ENV=	LUA_SONAME="liblua-${LUA_VER}.so.${LUA_VER_SH}"
 MAKE_ARGS=	__MAKE_CONF=${NONEXISTENT}
 # liblua.so requires libm, so make sure it has an explicit dependency
 # so that applications need not second-guess lua's dependencies.
-LDFLAGS+=	-lm
+LDFLAGS+=	-lm -pthread
 
 MAN1=		lua-${LUA_VER}.1 luac-${LUA_VER}.1
 DOCSDIR=	${PREFIX}/share/doc/${LUA_SUBDIR}
diff --git a/lang/lua/files/patch-src-Makefile b/lang/lua/files/patch-src-Makefile
index 58691571d486..87b14233f2ce 100644
--- a/lang/lua/files/patch-src-Makefile
+++ b/lang/lua/files/patch-src-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig	2008-01-19 17:37:58.000000000 -0200
-+++ Makefile	2008-08-10 16:00:41.000000000 -0300
-@@ -9,7 +9,8 @@
+--- Makefile.orig	2012-02-13 22:41:22.000000000 +0200
++++ Makefile	2013-08-05 15:56:32.000000000 +0300
+@@ -9,10 +9,11 @@
  
  CC= gcc
  CFLAGS= -O2 -Wall $(MYCFLAGS)
@@ -9,7 +9,11 @@
 +AR= ar
  RANLIB= ranlib
  RM= rm -f
- LIBS= -lm $(MYLIBS)
+-LIBS= -lm $(MYLIBS)
++LIBS= -lm -pthread $(MYLIBS)
+ 
+ MYCFLAGS=
+ MYLDFLAGS=
 @@ -31,12 +32,13 @@
  
  LUA_T=	lua
diff --git a/lang/lua52/Makefile b/lang/lua52/Makefile
index 519cda30bca9..a8d4ed9d2832 100644
--- a/lang/lua52/Makefile
+++ b/lang/lua52/Makefile
@@ -3,6 +3,7 @@
 
 PORTNAME=	lua
 PORTVERSION=	5.2.2
+PORTREVISION=	1
 CATEGORIES=	lang
 MASTER_SITES=	http://www.lua.org/ftp/
 
@@ -30,7 +31,7 @@ MAKE_ENV=	LUA_SONAME="liblua-${LUA_VER}.so.${LUA_VER_SH}" \
 		MYCFLAGS="${CFLAGS}" MYLDFLAGS="${LDFLAGS}"
 # liblua.so requires libm, so make sure it has an explicit dependency
 # so that applications need not second-guess lua's dependencies.
-LDFLAGS+=	-lm
+LDFLAGS+=	-lm -pthread
 
 MAN1=		lua-${LUA_VER}.1 luac-${LUA_VER}.1
 DOCSDIR=	${PREFIX}/share/doc/${LUA_SUBDIR}
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0