summaryrefslogtreecommitdiff
path: root/x11/lumina-core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/lumina-core/Makefile')
-rw-r--r--x11/lumina-core/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11/lumina-core/Makefile b/x11/lumina-core/Makefile
index b57a924e2165..c72870c3fca7 100644
--- a/x11/lumina-core/Makefile
+++ b/x11/lumina-core/Makefile
@@ -39,11 +39,11 @@ RUN_DEPENDS+= gstreamer1-plugins-core>=0:multimedia/gstreamer1-plugins-core
MAKE_JOBS_UNSAFE=yes
-USES= qmake
+USES= qmake qt:5
USE_GL= gl
USE_XORG= x11 xdamage xcb
USE_LDCONFIG= yes
-USE_QT5= core gui widgets network svg multimedia imageformats \
+USE_QT= core gui widgets network svg multimedia imageformats \
buildtools_build x11extras concurrent
USE_GITHUB= yes
GH_ACCOUNT= trueos
@@ -51,13 +51,13 @@ GH_PROJECT= lumina
GH_TAGNAME= b6536c1547571ae8dd0618bed752e2e0025bf2a7
WRKSRC_SUBDIR= src-qt5/core
-#Setup the qmake configuration options
+#Setup the qmake qt:5 configuration options
.if ${PORT_OPTIONS:MTRUEOS}
QMAKE_ARGS= DEFAULT_SETTINGS=TrueOS
.endif
.if${PORT_OPTIONS:MI18N}
-USE_QT5+= linguist_build
+USE_QT+= linguist_build
QMAKE_ARGS+=CONFIG+=WITH_I18N
.endif