summaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt5-widgets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt5-widgets/Makefile')
-rw-r--r--x11-toolkits/py-qt5-widgets/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/py-qt5-widgets/Makefile b/x11-toolkits/py-qt5-widgets/Makefile
index ad67fc64427c..08ce38c0eba7 100644
--- a/x11-toolkits/py-qt5-widgets/Makefile
+++ b/x11-toolkits/py-qt5-widgets/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= widgets
-PORTREVISION= 1
CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +14,7 @@ PYQT_DIST= yes
USES= gl python pyqt:5 qt:5
USE_GL= gl
-USE_PYQT= sip_build core_run gui_run
+USE_PYQT= sip_build core_run gui_run
USE_PYTHON= concurrent flavors py3kplist
USE_QT= core gui widgets qmake_build
@@ -29,4 +28,7 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtWidgets.so
+
.include <bsd.port.mk>