summaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt5-quick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt5-quick/Makefile')
-rw-r--r--x11-toolkits/py-qt5-quick/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/py-qt5-quick/Makefile b/x11-toolkits/py-qt5-quick/Makefile
index 7354183bde40..cffbeb61682a 100644
--- a/x11-toolkits/py-qt5-quick/Makefile
+++ b/x11-toolkits/py-qt5-quick/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= quick
-PORTREVISION= 1
CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
@@ -13,10 +12,11 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtQuick
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
-USE_PYQT= sip_build core_run gui_run
+USES= gl python pyqt:5 qt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run gui_run
USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core declarative qmake_build
+USE_QT= core declarative gui qmake_build network
OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
@@ -28,4 +28,7 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtQuick.so
+
.include <bsd.port.mk>