summaryrefslogtreecommitdiff
path: root/x11-servers/XttXF86srv-common/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers/XttXF86srv-common/Makefile')
-rw-r--r--x11-servers/XttXF86srv-common/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-servers/XttXF86srv-common/Makefile b/x11-servers/XttXF86srv-common/Makefile
index cec1cdf8432b..ff4a2f76c3a8 100644
--- a/x11-servers/XttXF86srv-common/Makefile
+++ b/x11-servers/XttXF86srv-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 15 April 1998
# Whom: Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
#
-# $Id: Makefile,v 1.6 1998/10/15 01:18:23 jseger Exp $
+# $Id: Makefile,v 1.7 1998/10/22 00:25:53 steve Exp $
#
DISTNAME= xc
@@ -82,6 +82,8 @@ TMPPLIST= ${WRKDIR}/.PLIST.common.mktmp
BROKEN= This port is dummy.
.endif
+.include <bsd.port.pre.mk>
+
.if defined(SERVER)
.if ${SERVER} != xfs
pre-fetch:
@@ -139,14 +141,14 @@ do-install:
@( \
cd ${WRKSRC}/lib/font; \
${SETENV} ${MAKE_ENV} ${MAKE} install; \
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libfont.so.1.0 ${PREFIX}/lib/libfont.so; \
- fi; \
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib; \
${INSTALL_SCRIPT} ${FILESDIR}/mkfontdir.pl ${PREFIX}/bin; \
${MKDIR} ${DOCDIR}; \
${INSTALL_DATA} ${XTTDIR}/xtt10-*.eng ${DOCDIR}; \
${INSTALL_DATA} ${XTTDIR}/xtt10-*.jis ${DOCDIR} )
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libfont.so.1.0 ${PREFIX}/lib/libfont.so
+.endif
.elif defined(SERVER) && ${SERVER} == xfs
do-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${INSTALL_PROGRAM} ${WRKSRC}/programs/xfs/xfs ${PREFIX}/bin/xfs.xtt
@@ -163,4 +165,4 @@ post-install:
post-package:
@${TOUCH} ${TOUCH_FLAGS} ${PACKAGE_COOKIE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>