summaryrefslogtreecommitdiff
path: root/www/serendipity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/serendipity/Makefile')
-rw-r--r--www/serendipity/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/serendipity/Makefile b/www/serendipity/Makefile
index 26152cf4af92..2c50a1348372 100644
--- a/www/serendipity/Makefile
+++ b/www/serendipity/Makefile
@@ -3,6 +3,7 @@
PORTNAME= serendipity
PORTVERSION= 1.7.8
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/php-blog/${PORTNAME}/${PORTVERSION}
@@ -15,6 +16,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= YES
SERENDIPITY?= www/${PORTNAME}
#PLIST_SUB+= SERENDIPITY=${SERENDIPITY}
+PLIST_SUB+= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
USE_PHP= session pcre gd openssl mbstring iconv zlib xml
#SUB_LIST+= SERENDIPITY=${SERENDIPITY}
SUB_FILES= pkg-message
@@ -45,6 +47,5 @@ do-install:
@-${MKDIR} ${STAGEDIR}${PREFIX}/${SERENDIPITY}
@${CHMOD} 755 ${STAGEDIR}${PREFIX}/${SERENDIPITY}
@(cd ${WRKSRC} && ${CP} -R * ${STAGEDIR}${PREFIX}/${SERENDIPITY}/ )
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${PREFIX}/${SERENDIPITY}
.include <bsd.port.mk>