summaryrefslogtreecommitdiff
path: root/www/mod_php3/scripts/configure.php
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_php3/scripts/configure.php')
-rw-r--r--www/mod_php3/scripts/configure.php10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index b09c72ded1d5..5e7cad763a09 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`/usr/bin/mktemp -t checklist`
+
if [ "${BATCH}" ]; then
set \"zlib\" \"MySQL\"
else
@@ -32,14 +34,14 @@ gettext "gettext library support" OFF \
YP "YP/NIS support" OFF \
sysvsem "System V semaphore support" OFF \
sysvshm "System V shared memory support" OFF \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then