summaryrefslogtreecommitdiff
path: root/textproc/xhtml-11/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xhtml-11/Makefile')
-rw-r--r--textproc/xhtml-11/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/xhtml-11/Makefile b/textproc/xhtml-11/Makefile
new file mode 100644
index 000000000000..63798835b090
--- /dev/null
+++ b/textproc/xhtml-11/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XHTML 1.1 DTD
+# Date created: 18 April 2003
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhtml
+PORTVERSION= 1.1
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= http://www.w3.org/TR/xhtml11/
+DISTNAME= xhtml11
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= W3C's XHTML 1.1 DTD
+
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+WRKSRC= ${WRKDIR}/xhtml11-20010531
+NO_BUILD= yes
+PLIST_SUB= XMLCATMGR=${XMLCATMGR} DTDDIR=${DTDDIR} \
+ CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
+
+DTDDIR= ${PREFIX}/share/xml/${PORTNAME}/${PORTVERSION}
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+
+do-install:
+ ${MKDIR} ${DTDDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DTD/* ${DTDDIR}
+
+post-install:
+ ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} \
+ add CATALOG ${DTDDIR}/xhtml11.cat
+
+.include <bsd.port.mk>