summaryrefslogtreecommitdiff
path: root/textproc/ppower4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ppower4/Makefile')
-rw-r--r--textproc/ppower4/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/textproc/ppower4/Makefile b/textproc/ppower4/Makefile
index 3ec5f5fb36f5..c9da90b4af17 100644
--- a/textproc/ppower4/Makefile
+++ b/textproc/ppower4/Makefile
@@ -13,12 +13,16 @@ WWW= https://ctan.org/tex-archive/support/ppower4/
LICENSE= GPLv2 # version not really specified
-USES= zip
-USE_TEX= latex
+USES= tex zip
USE_JAVA= yes
+USE_TEX= latex
+
+NO_ARCH= yes
NO_BUILD= yes
+SUB_FILES= ppower4.sh
+SUB_LIST= JARFILE=${JAR_DIR}/pp4p.jar
+
NO_WRKSUBDIR= yes
-NO_ARCH= yes
JAR_DIR= ${JAVASHAREDIR}/${PORTNAME}
STY_DIR= ${PREFIX}/share/texmf/tex/latex/${PORTNAME}
@@ -31,9 +35,6 @@ EXAMPLE_FILES+= ${WRKSRC}/example.${i}
PLIST_SUB= STY_DIR="${STY_DIR:S,^${PREFIX}/,,}" \
JAR_DIR="${JAR_DIR:S,^${PREFIX}/,,}"
-SUB_FILES= ppower4.sh
-SUB_LIST= JARFILE=${JAR_DIR}/pp4p.jar
-
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_SUB= yes