summaryrefslogtreecommitdiff
path: root/security/p5-Net-SSLeay/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Net-SSLeay/Makefile')
-rw-r--r--security/p5-Net-SSLeay/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/security/p5-Net-SSLeay/Makefile b/security/p5-Net-SSLeay/Makefile
index e12aa15d83f9..77e080f3c704 100644
--- a/security/p5-Net-SSLeay/Makefile
+++ b/security/p5-Net-SSLeay/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Net-SSLeay
-PORTVERSION= 1.55
+PORTVERSION= 1.57
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,26 +16,18 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
OPTIONS_DEFINE= EXAMPLES
-USES= perl5
-USE_PERL5= configure
CONFIGURE_ENV= OPENSSL_PREFIX=${OPENSSLBASE}
-REINPLACE_ARGS= -i ''
+USES= perl5 shebangfix
USE_OPENSSL= yes
+USE_PERL5= configure
PORTEXAMPLES= *
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${WRKSRC}/examples/*.pl
-.endif
+SHEBANG_FILES= examples/*.pl
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/examples/req.conf ${STAGEDIR}${EXAMPLESDIR}/req.conf
-.endif
.include <bsd.port.mk>