summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/code_saturne/Makefile6
-rw-r--r--science/libgeodecomp/Makefile4
-rw-r--r--science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake12
3 files changed, 15 insertions, 7 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 4d0af6cf4295..1ec74fdd4624 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -3,8 +3,8 @@
PORTNAME= code_saturne
PORTVERSION= 6.1.2
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= science parallel
MAINTAINER= thierry@FreeBSD.org
@@ -64,7 +64,7 @@ PARMETIS_CONFIGURE_ON= --with-metis-include="${LOCALBASE}/include/parmetis" \
--with-metis-lib="${LOCALBASE}/lib/parmetis"
PARMETIS_CONFIGURE_ENV= LIBS=-lexecinfo
SCOTCH_DESC= Support of Scotch
-SCOTCH_BUILD_DEPENDS= scotch>0:cad/scotch
+SCOTCH_LIB_DEPENDS= libscotch.so:cad/scotch
SCOTCH_CONFIGURE_ON= --with-scotch-include="${LOCALBASE}/include"
TEST_TARGET= check
@@ -86,7 +86,7 @@ CONFIGURE_ARGS+= --disable-openmp
.if ${PORT_OPTIONS:MDOCS}
USE_TEX= tex:build
-BUILD_DEPENDS+= fig2dev:print/transfig \
+BUILD_DEPENDS+= fig2dev:print/fig2dev \
doxygen:devel/doxygen \
dot:graphics/graphviz \
${PY_SPHINX}
diff --git a/science/libgeodecomp/Makefile b/science/libgeodecomp/Makefile
index fe9dc83bd2f7..d43af7ef88d1 100644
--- a/science/libgeodecomp/Makefile
+++ b/science/libgeodecomp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgeodecomp
PORTVERSION= 0.4.0
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= science devel
MASTER_SITES= http://www.libgeodecomp.org/archive/
@@ -35,7 +35,7 @@ SILO_LIB_DEPENDS= libsiloh5.so:science/silo
SILO_CMAKE_BOOL= WITH_SILO
SCOTCH_DESC= Enable graph partitioning based on Scotch/Scotch-PT
-SCOTCH_BUILD_DEPENDS= ${LOCALBASE}/lib/libscotch.a:cad/scotch
+SCOTCH_LIB_DEPENDS= libscotch.so:cad/scotch
SCOTCH_CMAKE_BOOL= WITH_SCOTCH
.include <bsd.port.mk>
diff --git a/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake b/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
index a5a5911f53c7..cafbd9109f96 100644
--- a/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
+++ b/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
@@ -1,6 +1,14 @@
---- CMakeModules/FindSCOTCH.cmake.orig 2020-09-20 01:42:12 UTC
+--- CMakeModules/FindSCOTCH.cmake.orig 2014-10-28 09:12:48 UTC
+++ CMakeModules/FindSCOTCH.cmake
-@@ -121,6 +121,7 @@ endif()
+@@ -114,13 +114,14 @@ find_library(PTSCOTCHERR_LIBRARY
+ )
+
+ #set(SCOTCH_DEBUG 1)
+-set(SCOTCH_LIBRARIES ${PTSCOTCH_LIBRARY})
++set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARY} ${SCOTCHERR_LIBRARY} ${PTSCOTCH_LIBRARY})
+ if (PTESMUMPS_LIBRARY)
+ set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${PTESMUMPS_LIBRARY})
+ endif()
set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${PTSCOTCHERR_LIBRARY})
# Try compiling and running test program