summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/erkale/Makefile7
-rw-r--r--science/libcint/files/patch-CMakeLists.txt15
2 files changed, 3 insertions, 19 deletions
diff --git a/science/erkale/Makefile b/science/erkale/Makefile
index 401f1ca66c55..844b8de1038c 100644
--- a/science/erkale/Makefile
+++ b/science/erkale/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libderiv.so:science/libint \
libgsl.so:math/gsl \
libhdf5.so:science/hdf5 \
libint.so:science/libint \
- libopenblas.so:math/openblas \
libsz.so:science/szip \
libxc.so:science/libxc
RUN_DEPENDS= ${LOCALBASE}/share/erkale/basis/6-21G.gbs:science/erkale-pseudopotentials
@@ -49,7 +48,7 @@ LIB_DEPENDS+= libomp.so:devel/llvm${LLVM_DEFAULT}
OPTIONS_SINGLE= LINALG
OPTIONS_SINGLE_LINALG= NETLIB OPENBLAS
-OPTIONS_DEFAULT= NETLIB
+OPTIONS_DEFAULT= OPENBLAS
LINALG_DESC= Linear algebra library
NETLIB_USES= blaslapack:netlib
@@ -58,8 +57,8 @@ NETLIB_LDFLAGS= ${LOCALBASE}/lib/libcblas.so ${LOCALBASE}/lib/liblapack.so ${LO
NETLIB_LIB_DEPENDS= libcblas.so:math/cblas
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=-lopenblas -DBLAS_LIBRARIES:STRING=-lopenblasp
-OPENBLAS_BROKEN= hits the number of threads limit: https://github.com/xianyi/OpenBLAS/issues/1882
+OPENBLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=-lopenblas -DBLAS_LIBRARIES:STRING=-lopenblas
+OPENBLAS_LIB_DEPENDS= libopenblas.so:math/openblas
# use clang from ports because cmake can't find OpenMP with base clang, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
# have the same compiler for both serial and parallel flavors so that performance numbers can be compared
diff --git a/science/libcint/files/patch-CMakeLists.txt b/science/libcint/files/patch-CMakeLists.txt
deleted file mode 100644
index a568548498f6..000000000000
--- a/science/libcint/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- CMakeLists.txt.orig 2018-03-26 22:49:26 UTC
-+++ CMakeLists.txt
-@@ -25,7 +25,11 @@ if(QUADMATH_FOUND)
- set(HAVE_QUADMATH_H 1 CACHE INTERNAL "Have QUADMATH")
- endif()
-
--find_package(BLAS REQUIRED)
-+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226959
-+#find_package(BLAS REQUIRED)
-+set(BLAS_FOUND ON)
-+set(BLAS_LINKER_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib -lopenblas -lopenblasp)
-+set(BLAS_LIBRARIES ${CMAKE_INSTALL_PREFIX}/lib/libopenblas.so ${CMAKE_INSTALL_PREFIX}/lib/libopenblasp.so)
-
- include(CheckFunctionExists)
- set(CMAKE_REQUIRED_INCLUDES math.h)