summaryrefslogtreecommitdiff
path: root/science/libcint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/libcint/Makefile')
-rw-r--r--science/libcint/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/science/libcint/Makefile b/science/libcint/Makefile
index 42fb2ec9b887..0cdbf56e371f 100644
--- a/science/libcint/Makefile
+++ b/science/libcint/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libcint
DISTVERSIONPREFIX= v
-DISTVERSION= 4.3.0
+DISTVERSION= 4.4.0
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -10,8 +10,9 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libopenblas.so:math/openblas
+TEST_DEPENDS= ${PYNUMPY}
-USES= cmake blaslapack:openblas
+USES= cmake blaslapack:openblas python:test
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -23,7 +24,13 @@ PLIST_FILES= include/cint.h \
lib/libcint.so.${PORTVERSION:R:R} \
lib/libcint.so.${PORTVERSION}
-do-test: # tests fail: https://github.com/sunqm/libcint/issues/54
+post-patch:
+ @${REINPLACE_CMD} -e "s|numpy\\.ctypeslib\\.load_library('libcint', .*$$|numpy.ctypeslib.load_library('libcint', '${BUILD_WRKSRC}')|" \
+ ${WRKSRC}/testsuite/test_cint4c1e.py \
+ ${WRKSRC}/testsuite/test_cint.py \
+ ${WRKSRC}/testsuite/test_3c2e.py
+
+do-test: # needs science/py-pyscf, pending https://github.com/pyscf/pyscf/issues/935
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DENABLE_TEST:BOOL=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \