summaryrefslogtreecommitdiff
path: root/science/code_saturne/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/code_saturne/Makefile')
-rw-r--r--science/code_saturne/Makefile71
1 files changed, 26 insertions, 45 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 3f08b8be3afd..91a58c275fc0 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -1,8 +1,7 @@
PORTNAME= code_saturne
-PORTVERSION= 7.1.1
-DISTVERSIONPREFIX= v
-PORTREVISION= 11
+PORTVERSION= 8.0.0
CATEGORIES= science parallel
+MASTER_SITES= https://www.code-saturne.org/releases/
MAINTAINER= thierry@FreeBSD.org
COMMENT= EDF's general purpose Computational Fluid Dynamics (CFD) software
@@ -11,76 +10,62 @@ WWW= https://www.code-saturne.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= gsed:textproc/gsed
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR} \
+ gsed:textproc/gsed
LIB_DEPENDS= libsysinfo.so:devel/libsysinfo \
libcgns.so:science/cgnslib \
+ libpetsc.so:science/PETSc \
+ libHYPRE.so:science/hypre \
libhdf5.so:science/hdf5 \
+ libscotch.so:cad/scotch \
+ libsmumps.so:math/mumps \
+ libcblas.so:math/cblas \
libmedC.so:french/med
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR} \
+ pbs-config:sysutils/torque \
xmgrace:math/grace \
bash:shells/bash \
xterm:x11/xterm
-USE_GITHUB= yes
-GH_ACCOUNT= code-saturne
-
-USES= autoreconf bison compiler:c11 fortran gettext gnome gmake \
- iconv localbase libtool pyqt:5 python shebangfix xorg
+USES= autoreconf bison blaslapack compiler:c11 fortran gettext gnome gmake \
+ iconv localbase libtool mpi pyqt:5 python shebangfix xorg
USE_GNOME= libxml2
USE_PYQT= pyqt5 sip
USE_XORG= x11
-SHEBANG_FILES= install_saturne.py tests/unittests.py bin/*.py build-aux/*.py
-CFLAGS+= -D__XSI_VISIBLE
+SHEBANG_FILES= install_saturne.py tests/unittests.py build-aux/*.py
+CFLAGS+= -D__XSI_VISIBLE -Wno-error=incompatible-function-pointer-types
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-salome --without-salome-yacs --without-salome-kernel \
- --without-salome-gui --enable-python
-CONFIGURE_ENV= ac_cv_path_SED=${LOCALBASE}/bin/gsed
+ --without-salome-gui --enable-python \
+ --with-blas=yes --with-blas-type=BLAS \
+ --with-blas-include=${LOCALBASE}/include/cblas \
+ --with-blas-lib=${LOCALBASE}/lib \
+ --with-hypre="${LOCALBASE}" --with-mpi \
+ --with-mumps="${LOCALBASE}" --with-petsc="${LOCALBASE}" \
+ --with-scotch-include="${LOCALBASE}/include"
+CONFIGURE_ENV= ac_cv_path_SED=${LOCALBASE}/bin/gsed ldflags_rpath="-R" \
+ MUMPS_LIBS="-lmpiseq -llapack"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
BINARY_ALIAS= python=${PYTHON_CMD} \
pyrcc5=pyrcc5-${PYTHON_VER} \
pyuic5=pyuic5-${PYTHON_VER}
-OPTIONS_DEFINE= DOCS EXAMPLES BATCH BLAS HYPRE MPICH MUMPS PETSC SCOTCH
-OPTIONS_DEFAULT= BATCH BLAS HYPRE METIS MPICH MUMPS PETSC SCOTCH
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= METIS
OPTIONS_RADIO= METIS
OPTIONS_RADIO_METIS= METIS PARMETIS
OPTIONS_SUB= yes
-BLAS_DESC= Support of BLAS
-BLAS_USES= blaslapack
-BLAS_CONFIGURE_ON= --with-blas=yes --with-blas-type=BLAS \
- --with-blas-include=${LOCALBASE}/include/cblas \
- --with-blas-lib=${LOCALBASE}/lib
-BLAS_LIB_DEPENDS= libcblas.so:math/cblas
-BATCH_DESC= Use Torque to submit batches
-BATCH_RUN_DEPENDS= pbs-config:sysutils/torque
-HYPRE_DESC= Support of HYPRE
-HYPRE_BUILD_DEPENDS= hypre>0:science/hypre
-HYPRE_RUN_DEPENDS= hypre>0:science/hypre
-HYPRE_CONFIGURE_ON= --with-hypre="${LOCALBASE}"
-MPICH_USES= mpi
-MPICH_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPICH_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPICH_CONFIGURE_WITH= mpi
METIS_DESC= Support of METIS
METIS_LIB_DEPENDS= libmetis.so:math/metis
METIS_CONFIGURE_ON= --with-metis-include="${LOCALBASE}/include"
-MUMPS_DESC= Support of MUMPS
-MUMPS_LIB_DEPENDS= libsmumps.so:math/mumps
-MUMPS_CONFIGURE_ON= --with-mumps="${LOCALBASE}"
-MUMPS_CONFIGURE_ENV= MUMPS_LIBS="-lmpiseq -llapack"
PARMETIS_DESC= Support of ParMETIS
PARMETIS_LIB_DEPENDS= libparmetis.so:math/parmetis
PARMETIS_CONFIGURE_ON= --with-metis-include="${LOCALBASE}/include/parmetis" \
--with-metis-lib="${LOCALBASE}/lib/parmetis"
PARMETIS_CONFIGURE_ENV= LIBS=-lexecinfo
-PETSC_DESC= Support of PETSc
-PETSC_LIB_DEPENDS= libpetsc.so:science/PETSc
-PETSC_CONFIGURE_ON= --with-petsc="${LOCALBASE}"
-SCOTCH_DESC= Support of Scotch
-SCOTCH_LIB_DEPENDS= libscotch.so:cad/scotch
-SCOTCH_CONFIGURE_ON= --with-scotch-include="${LOCALBASE}/include"
TEST_TARGET= check
@@ -124,8 +109,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-
.include <bsd.port.mk>