summaryrefslogtreecommitdiff
path: root/print/qpdfview
diff options
context:
space:
mode:
Diffstat (limited to 'print/qpdfview')
-rw-r--r--print/qpdfview/Makefile1
-rw-r--r--print/qpdfview/files/patch-qpdfview.pri8
2 files changed, 8 insertions, 1 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 8ee8e8ad46b6..183cb009d44a 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -18,7 +18,6 @@ USE_GL= gl
USE_LDCONFIG= yes
USE_QT= concurrent core dbus gui imageformats linguisttools \
printsupport sql sql-sqlite3 svg widgets xml buildtools:build
-USE_CXXSTD= c++17
QMAKE_SOURCE_PATH= ${PORTNAME}.pro
diff --git a/print/qpdfview/files/patch-qpdfview.pri b/print/qpdfview/files/patch-qpdfview.pri
new file mode 100644
index 000000000000..266e872da9ac
--- /dev/null
+++ b/print/qpdfview/files/patch-qpdfview.pri
@@ -0,0 +1,8 @@
+--- qpdfview.pri.orig 2024-01-02 16:01:53 UTC
++++ qpdfview.pri
+@@ -12,4 +12,4 @@ os2:include(qpdfview_os2.pri)
+ win32:include(qpdfview_win32.pri)
+ os2:include(qpdfview_os2.pri)
+
+-CONFIG += c++11
++CONFIG += c++17