summaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/pkg/Makefile')
-rw-r--r--ports-mgmt/pkg/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index fddf0a1d922e..36ac998733da 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -28,6 +28,8 @@ PORTSCOUT= ignore:1
USE_SUBMAKE= yes
CFLAGS+= -Wno-error
+OPTIONS_DEFINE= DOCS
+
.if !exists(/usr/include/jail.h)
EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.endif
@@ -79,9 +81,11 @@ PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
@${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
${STAGEDIR}${PREFIX}/lib/libpkg.a
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
+
.include <bsd.port.post.mk>