summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/openmq/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/openmq/Makefile b/net/openmq/Makefile
index 93b6d612a8c1..7ff88384db5f 100644
--- a/net/openmq/Makefile
+++ b/net/openmq/Makefile
@@ -43,7 +43,11 @@ USE_RC_SUBR= imq
SUB_FILES= pkg-message
.endif
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${JAVA_PORT_VERSION:M1.8.*}
+BROKEN= Does not build with JDK 1.8
+.endif
# Get the bootstrap jars in place before the build starts, because
# pointyhat doesn't allow them to be downloaded by the "bootstrap"
@@ -121,4 +125,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/dist/mq/lib/imqxm.jar ${STAGEDIR}${JAVAJARDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>