summaryrefslogtreecommitdiff
path: root/net/zebra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/zebra/Makefile')
-rw-r--r--net/zebra/Makefile53
1 files changed, 51 insertions, 2 deletions
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index 3ab4ad4f879a..d41ba2089d92 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -20,13 +20,62 @@ COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4 route software (server/reflector)
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra --enable-vtysh
+CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra
SCRIPTS_ENV= WRKDIRPREFIX=${WRKDIRPREFIX}
MAN1= vtysh.1
MAN8= bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8
INFO= zebra
+.if defined (WITHOUT_IPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+WITHOUT_OSPF6D= yes
+WITHOUT_RIPNGD= yes
+.endif
+
+.if !defined(WITHOUT_BGPD)
+PLIST_SUB+= BGPD=""
+.else
+CONFIGURE_ARGS+=--disable-bgpd
+PLIST_SUB+= BGPD="@comment "
+.endif
+
+.if !defined(WITHOUT_OSPF6D)
+PLIST_SUB+= OSPF6D=""
+.else
+CONFIGURE_ARGS+=--disable-ospf6d
+PLIST_SUB+= OSPF6D="@comment "
+.endif
+
+.if !defined(WITHOUT_OSPFD)
+PLIST_SUB+= OSPF6D=""
+PLIST_SUB+= OSPFD=""
+.else
+CONFIGURE_ARGS+=--disable-ospfd
+PLIST_SUB+= OSPFD="@comment "
+.endif
+
+.if !defined(WITHOUT_RIPD)
+PLIST_SUB+= RIPD=""
+.else
+CONFIGURE_ARGS+=--disable-ripd
+PLIST_SUB+= RIPD="@comment "
+.endif
+
+.if !defined(WITHOUT_RIPNGD)
+PLIST_SUB+= RIPNGD=""
+.else
+CONFIGURE_ARGS+=--disable-ripngd
+PLIST_SUB+= RIPNGD="@comment "
+.endif
+
+.if !defined(WITHOUT_VTYSH)
+PLIST_SUB+= VTYSH=""
+CONFIGURE_ARGS+=--enable-vtysh
+.else
+PLIST_SUB+= VTYSH="@comment "
+.endif
+
.if !defined(BATCH)
pre-configure:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
@@ -40,7 +89,7 @@ post-clean:
.endif
post-install:
- @( cd ${WRKSRC}/doc; rm -f zebra*info*; ${MAKE} zebra.info install )
+ @( cd ${WRKSRC}/doc; ${RM} -f zebra*info*; ${MAKE} zebra.info install )
@${ECHO} "===> installing zebra startup file..."
@${SED} -e "s=!!PREFIX!!=${PREFIX}=" \
< ${FILESDIR}/zebractl.sh \