summaryrefslogtreecommitdiff
path: root/net/openldap21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap21/Makefile')
-rw-r--r--net/openldap21/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/openldap21/Makefile b/net/openldap21/Makefile
index 0c12e7e8ee5d..89db892a196b 100644
--- a/net/openldap21/Makefile
+++ b/net/openldap21/Makefile
@@ -15,7 +15,7 @@
#
PORTNAME= openldap21
-PORTVERSION= 2.1.12
+PORTVERSION= 2.1.16
PORTREVISION= 0
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -38,23 +38,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ck@cksoft.de
COMMENT= Open source LDAP client and server software
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+LIB_DEPENDS+= db41:${PORTSDIR}/databases/db41
-CXXFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/db4
-CPPFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/db4
+CXXFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/db41
+CPPFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/db41
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
HAS_CONFIGURE= yes
-LATEST_LINK= openldap21
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+=--prefix=${PREFIX} \
- --enable-bdb
-
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --enable-bdb \
+ --enable-crypt
# ------------------------------------------------------------------------------
# common configure