summaryrefslogtreecommitdiff
path: root/net/cflowd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/cflowd/Makefile')
-rw-r--r--net/cflowd/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/cflowd/Makefile b/net/cflowd/Makefile
index 6bb1295b208f..bc89beade5b1 100644
--- a/net/cflowd/Makefile
+++ b/net/cflowd/Makefile
@@ -7,11 +7,16 @@
PORTNAME= cflowd
PORTVERSION= 2-1-b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.caida.org/pub/cflowd/
DISTNAME= ${PORTNAME}-${PORTVERSION}
+.if defined(CFLOWD_FLOWSCAN_PATCH)
+PATCH_SITES= http://net.doit.wisc.edu/~plonka/cflowd/
+PATCHFILES= cflowd-2-1-b1-djp.patch
+.endif
+
MAINTAINER= andreas@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libArts.a:${PORTSDIR}/net/arts++
@@ -25,4 +30,10 @@ CONFIGURE_ARGS+=--enable-shared --with-artspp=${PREFIX}
MANL= cfdases.l cfdifmatrix.l cfdnets.l cfdnexthops.l \
cfdportmatrix.l cfdprotos.l cfdtos.l flowdump.l flowwatch.l
+.if !defined(CFLOWD_FLOWSCAN_PATCH)
+pre-everything:
+ @${ECHO} "you can compile cflowd with patches for FlowScan by typing:"
+ @${ECHO} "make CFLOWD_FLOWSCAN_PATCH=yes"
+.endif
+
.include <bsd.port.mk>