summaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoin/Makefile')
-rw-r--r--net-p2p/bitcoin/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 2640193f9df8..897fc26b3e8a 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
BROKEN_powerpc64= fails to compile: util.cpp: undefined reference to boost::program_options::to_internal
-USES= autoreconf compiler:c++11-lib gmake libtool pkgconfig shebangfix ssl
+USES= autoreconf compiler:c++11-lib gmake libtool pkgconfig qt:5 shebangfix ssl
USE_GITHUB= yes
GNU_CONFIGURE= yes
@@ -25,13 +25,14 @@ SLAVE_PORT?= no
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
USES+= desktop-file-utils
-USE_QT5= core gui network widgets \
+USE_QT= core gui network widgets \
buildtools_build linguisttools_build qmake_build
BUILD_DEPENDS+= protoc:devel/protobuf
LIB_DEPENDS+= libprotobuf.so:devel/protobuf
-TESTS_USE= QT5=testlib
+TESTS_USES= qt:5
+TESTS_USE= QT=testlib
TESTS_PLIST_FILES= bin/test_bitcoin-qt \
bin/test_bitcoin
.endif
@@ -51,7 +52,8 @@ WALLET_BDBMODERN_DESC= Wallet using modern BDB 5.x or 6.x
ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= dbus
-DBUS_USE= QT5=dbus
+DBUS_USES= qt:5
+DBUS_USE= QT=dbus
DEBUG_CONFIGURE_ENABLE= debug
DEBUG_INSTALL_TARGET_OFF= install-strip