summaryrefslogtreecommitdiff
path: root/net-mgmt/cacti-spine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/cacti-spine/Makefile')
-rw-r--r--net-mgmt/cacti-spine/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-mgmt/cacti-spine/Makefile b/net-mgmt/cacti-spine/Makefile
index 30e71db5f8db..fdc520046cc1 100644
--- a/net-mgmt/cacti-spine/Makefile
+++ b/net-mgmt/cacti-spine/Makefile
@@ -21,19 +21,19 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --with-snmp=${LOCALBASE}
USE_MYSQL= YES
USE_OPENSSL= YES
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
-.for file in config.guess config.sub ltmain.sh
- @${LN} -fs ${LIBTOOL_SHAREDIR}/${file} ${WRKSRC}/config/${file}
-.endfor
- @${LN} -fs ${LIBTOOL} ${WRKSRC}/libtool
@${REINPLACE_CMD} 's,#define\ *DEFAULT_CONF_FILE .*,#define DEFAULT_CONF_FILE "${PREFIX}/etc/spine.conf",' ${WRKSRC}/spine.h
+pre-configure:
+ @(cd ${WRKSRC} ; ${LIBTOOLIZE} --copy --force --install)
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/spine ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/spine.conf ${EXAMPLESDIR}
@[ -e ${PREFIX}/etc/spine.conf ] || \
${INSTALL_DATA} ${EXAMPLESDIR}/spine.conf ${PREFIX}/etc/
+
.include <bsd.port.mk>