summaryrefslogtreecommitdiff
path: root/net-im/qxmpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/qxmpp/Makefile')
-rw-r--r--net-im/qxmpp/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-im/qxmpp/Makefile b/net-im/qxmpp/Makefile
index ca77e6e795dc..de2d18bcd3ed 100644
--- a/net-im/qxmpp/Makefile
+++ b/net-im/qxmpp/Makefile
@@ -16,10 +16,12 @@ CONFLICTS?= ${PORTNAME}-qt5-[0-9]*
USES= qmake pathfix pkgconfig libtool
.if defined(QXMPP_SLAVE)
-USE_QT5= core gui network xml buildtools_build
+USES+= qt:5
+USE_QT= core gui network xml buildtools_build
PLIST_SUB= QDNS="@comment "
.else
-USE_QT4= corelib gui network qtestlib xml uic_build moc_build \
+USES+= qt:4
+USE_QT= corelib gui network qtestlib xml uic_build moc_build \
rcc_build
PLIST_SUB= QDNS=""
.endif