summaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ls-lint/Makefile20
-rw-r--r--misc/ls-lint/distinfo5
-rw-r--r--misc/ls-lint/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index c1ef2e5c2989..107fc608f44d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -246,6 +246,7 @@
SUBDIR += locale-en_DK
SUBDIR += localedata
SUBDIR += logsurfer
+ SUBDIR += ls-lint
SUBDIR += lscolors
SUBDIR += lsix
SUBDIR += lv
diff --git a/misc/ls-lint/Makefile b/misc/ls-lint/Makefile
new file mode 100644
index 000000000000..2a863a63f747
--- /dev/null
+++ b/misc/ls-lint/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= ls-lint
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.1
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Directory and filename linter
+WWW= https://ls-lint.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/loeffel-io/ls-lint/v2
+GO_TARGET= ./cmd/ls_lint
+
+PLIST_FILES= bin/ls_lint
+
+.include <bsd.port.mk>
diff --git a/misc/ls-lint/distinfo b/misc/ls-lint/distinfo
new file mode 100644
index 000000000000..31644e9c88ad
--- /dev/null
+++ b/misc/ls-lint/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1693291932
+SHA256 (go/misc_ls-lint/ls-lint-v2.0.1/v2.0.1.mod) = 81e884b8096e9dfe0d6f55aa790edef7397cd27ab3ab9bc70ee22e05ecf909a6
+SIZE (go/misc_ls-lint/ls-lint-v2.0.1/v2.0.1.mod) = 154
+SHA256 (go/misc_ls-lint/ls-lint-v2.0.1/v2.0.1.zip) = 94edb33f4c93f63214ddea52554c10d52945fc681a0ad0e293fd67f564757a5c
+SIZE (go/misc_ls-lint/ls-lint-v2.0.1/v2.0.1.zip) = 56799
diff --git a/misc/ls-lint/pkg-descr b/misc/ls-lint/pkg-descr
new file mode 100644
index 000000000000..3a18b1e57507
--- /dev/null
+++ b/misc/ls-lint/pkg-descr
@@ -0,0 +1,10 @@
+ls-lint is an extremely fast directory and filename linter.
+
+Features:
+* Minimal setup with simple rules managed in one single .ls-lint.yml file.
+* Works for directory and file names - all extensions supported - full unicode
+ support.
+* Incredibly fast - lints thousands of files and directories in milliseconds.
+* Support for Windows, MacOS and Linux + NPM Package + GitHub Action & Docker
+ Image.
+* Almost zero third-party dependencies (only go-yaml and doublestar).