summaryrefslogtreecommitdiff
path: root/misc/qt4-qtconfig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/qt4-qtconfig/Makefile')
-rw-r--r--misc/qt4-qtconfig/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/misc/qt4-qtconfig/Makefile b/misc/qt4-qtconfig/Makefile
index a3ae6b248eb4..401eaf29d899 100644
--- a/misc/qt4-qtconfig/Makefile
+++ b/misc/qt4-qtconfig/Makefile
@@ -10,10 +10,9 @@ PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 4 graphical configuration utility
-USES= pkgconfig
-USE_QT4= qmake_build moc_build rcc_build uic_build \
+USES= pkgconfig qmake:no_env qt-dist:4
+USE_QT= moc_build rcc_build uic_build \
corelib dbus gui xml
-QT_DIST= yes
HAS_CONFIGURE= yes
@@ -42,7 +41,8 @@ OPTIONS_DEFINE= PHONON
OPTIONS_DEFAULT=PHONON
PHONON_DESC= Phonon multimedia framework support (implies GStreamer)
-PHONON_USE= GSTREAMER=yes QT4=phonon,phonon-gst
+PHONON_USES= qt-dist:4
+PHONON_USE= GSTREAMER=yes QT=phonon,phonon-gst
PHONON_CONFIGURE_ON= -phonon -gstreamer
PHONON_CONFIGURE_OFF= -no-phonon -no-gstreamer