summaryrefslogtreecommitdiff
path: root/misc/earthview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/earthview/Makefile')
-rw-r--r--misc/earthview/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/earthview/Makefile b/misc/earthview/Makefile
new file mode 100644
index 000000000000..fb8c584cff6f
--- /dev/null
+++ b/misc/earthview/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: earthview
+# Date created: Sep 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= earthview
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+USE_XLIB= yes
+CFLAGS+= -I${X11BASE}/include
+ALL_TARGET= earthview
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%CC%%|${CC}|g" \
+ -e "s|%%CFLAGS%%|${CFLAGS}|g" -e "s|%%X11BASE%%|${X11BASE}|g" \
+ ${WRKSRC}/Makefile
+
+pre-build:
+ @${RM} -f ${WRKSRC}/earthview
+
+.include <bsd.port.mk>