summaryrefslogtreecommitdiff
path: root/math/octave-forge-bim
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-bim')
-rw-r--r--math/octave-forge-bim/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/octave-forge-bim/Makefile b/math/octave-forge-bim/Makefile
index dad3f27550c5..b8a543351aec 100644
--- a/math/octave-forge-bim/Makefile
+++ b/math/octave-forge-bim/Makefile
@@ -12,6 +12,10 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
RUN_DEPENDS+= ${TARBALLS_DIR}/fpl.tar.gz:${PORTSDIR}/math/octave-forge-fpl
RUN_DEPENDS+= ${TARBALLS_DIR}/msh.tar.gz:${PORTSDIR}/math/octave-forge-msh
@@ -22,6 +26,6 @@ do-build:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${DISTNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>