summaryrefslogtreecommitdiff
path: root/mail/py-notmuch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/py-notmuch/Makefile')
-rw-r--r--mail/py-notmuch/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/mail/py-notmuch/Makefile b/mail/py-notmuch/Makefile
index 1f7a5d7a3036..f3dfde1f6e10 100644
--- a/mail/py-notmuch/Makefile
+++ b/mail/py-notmuch/Makefile
@@ -1,25 +1,29 @@
# $FreeBSD$
-PORTNAME= notmuch
-PORTVERSION= 0.25
CATEGORIES= mail python
-MASTER_SITES= http://notmuchmail.org/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= geier@lostpackets.de
-COMMENT= Python binding of the notmuch mail search and indexing library
-
-LICENSE= GPLv3+
-LICENSE_FILE= ${WRKSRC}/../../COPYING-GPL-3
+COMMENT= Python interface for the Notmuch email search and tagging library
LIB_DEPENDS= libnotmuch.so:mail/notmuch
-WRKSRC_SUBDIR= bindings/python
-
USES= python
USE_PYTHON= autoplist distutils
+
+MASTERDIR= ${.CURDIR}/../notmuch
NO_ARCH= yes
+PORTDOCS= python/
+WRKSRC_SUBDIR= bindings/python
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+
+do-build-DOCS-on:
+ @${MAKE_CMD} -C ${WRKSRC}/docs html
-MAKE_ENV+= PYTHONCMD=${PYTHON_CMD}
+do-install-DOCS-on:
+ cd ${WRKSRC}/docs/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/python
+ @${RM} ${STAGEDIR}${DOCSDIR}/python/.buildinfo
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"