summaryrefslogtreecommitdiff
path: root/mail/postfix-current/files/extra-patch-blacklistd
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-current/files/extra-patch-blacklistd')
-rw-r--r--mail/postfix-current/files/extra-patch-blacklistd53
1 files changed, 26 insertions, 27 deletions
diff --git a/mail/postfix-current/files/extra-patch-blacklistd b/mail/postfix-current/files/extra-patch-blacklistd
index 2b2bc712e667..c6811790ed66 100644
--- a/mail/postfix-current/files/extra-patch-blacklistd
+++ b/mail/postfix-current/files/extra-patch-blacklistd
@@ -1,6 +1,6 @@
# PR 225664: support blacklistd on FreeBSD >= 11.0
#
---- src/smtpd/Makefile.in.orig 2021-04-18 20:45:05 UTC
+--- src/smtpd/Makefile.in.orig 2023-05-21 16:54:34 UTC
+++ src/smtpd/Makefile.in
@@ -2,14 +2,14 @@ SHELL = /bin/sh
SRCS = smtpd.c smtpd_token.c smtpd_check.c smtpd_chat.c smtpd_state.c \
@@ -20,32 +20,7 @@
TESTSRC = smtpd_token_test.c
DEFS = -I. -I$(INC_DIR) -D$(SYSTYPE)
CFLAGS = $(DEBUG) $(OPT) $(DEFS)
---- src/smtpd/smtpd_sasl_glue.c.orig 2020-08-30 21:03:46 UTC
-+++ src/smtpd/smtpd_sasl_glue.c
-@@ -149,6 +149,7 @@
- #include "smtpd.h"
- #include "smtpd_sasl_glue.h"
- #include "smtpd_chat.h"
-+#include "pfilter.h" /* for blacklistd(8) */
-
- #ifdef USE_SASL_AUTH
-
-@@ -350,6 +351,10 @@ int smtpd_sasl_authenticate(SMTPD_STATE *state,
- else
- smtpd_chat_reply(state, "535 5.7.8 Error: authentication failed: %s",
- STR(state->sasl_reply));
-+
-+
-+ /* notify blacklistd of SASL authentication failure */
-+ pfilter_notify(1, vstream_fileno(state->client));
- return (-1);
- }
- /* RFC 4954 Section 6. */
---- src/smtpd/pfilter.h.orig 2021-05-06 19:00:00 UTC
-+++ src/smtpd/pfilter.h
-@@ -0,0 +1 @@
-+void pfilter_notify(int, int);
---- src/smtpd/pfilter.c.orig 2021-05-06 19:00:00 UTC
+--- src/smtpd/pfilter.c.orig 2023-11-17 14:38:32 UTC
+++ src/smtpd/pfilter.c
@@ -0,0 +1,19 @@
+#include "pfilter.h"
@@ -67,3 +42,27 @@
+ blstate = NULL;
+ }
+}
+--- src/smtpd/pfilter.h.orig 2023-11-17 14:38:32 UTC
++++ src/smtpd/pfilter.h
+@@ -0,0 +1 @@
++void pfilter_notify(int, int);
+--- src/smtpd/smtpd_sasl_glue.c.orig 2023-11-12 21:41:13 UTC
++++ src/smtpd/smtpd_sasl_glue.c
+@@ -153,6 +153,7 @@
+ #include "smtpd.h"
+ #include "smtpd_sasl_glue.h"
+ #include "smtpd_chat.h"
++#include "pfilter.h" /* for blacklistd(8) */
+
+ #ifdef USE_SASL_AUTH
+
+@@ -358,6 +359,9 @@ int smtpd_sasl_authenticate(SMTPD_STATE *state,
+ else
+ smtpd_chat_reply(state, "535 5.7.8 Error: authentication failed: %s",
+ reason);
++
++ /* notify blacklistd of SASL authentication failure */
++ pfilter_notify(1, vstream_fileno(state->client));
+ return (-1);
+ }
+ /* RFC 4954 Section 6. */