summaryrefslogtreecommitdiff
path: root/mail/postfix-current/files/extra-patch-blacklistd
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-current/files/extra-patch-blacklistd')
-rw-r--r--mail/postfix-current/files/extra-patch-blacklistd12
1 files changed, 6 insertions, 6 deletions
diff --git a/mail/postfix-current/files/extra-patch-blacklistd b/mail/postfix-current/files/extra-patch-blacklistd
index a4102e3ab129..2b2bc712e667 100644
--- a/mail/postfix-current/files/extra-patch-blacklistd
+++ b/mail/postfix-current/files/extra-patch-blacklistd
@@ -1,6 +1,6 @@
# PR 225664: support blacklistd on FreeBSD >= 11.0
#
---- src/smtpd/Makefile.in.orig 2019-01-27 22:17:15 UTC
+--- src/smtpd/Makefile.in.orig 2021-04-18 20:45:05 UTC
+++ src/smtpd/Makefile.in
@@ -2,14 +2,14 @@ SHELL = /bin/sh
SRCS = smtpd.c smtpd_token.c smtpd_check.c smtpd_chat.c smtpd_state.c \
@@ -20,9 +20,9 @@
TESTSRC = smtpd_token_test.c
DEFS = -I. -I$(INC_DIR) -D$(SYSTYPE)
CFLAGS = $(DEBUG) $(OPT) $(DEFS)
---- src/smtpd/smtpd_sasl_glue.c.orig 2018-08-26 18:48:45 UTC
+--- src/smtpd/smtpd_sasl_glue.c.orig 2020-08-30 21:03:46 UTC
+++ src/smtpd/smtpd_sasl_glue.c
-@@ -147,6 +147,7 @@
+@@ -149,6 +149,7 @@
#include "smtpd.h"
#include "smtpd_sasl_glue.h"
#include "smtpd_chat.h"
@@ -30,7 +30,7 @@
#ifdef USE_SASL_AUTH
-@@ -331,6 +332,10 @@ int smtpd_sasl_authenticate(SMTPD_ST
+@@ -350,6 +351,10 @@ int smtpd_sasl_authenticate(SMTPD_STATE *state,
else
smtpd_chat_reply(state, "535 5.7.8 Error: authentication failed: %s",
STR(state->sasl_reply));
@@ -41,11 +41,11 @@
return (-1);
}
/* RFC 4954 Section 6. */
---- src/smtpd/pfilter.h.orig 2018-02-04 15:36:49 UTC
+--- src/smtpd/pfilter.h.orig 2021-05-06 19:00:00 UTC
+++ src/smtpd/pfilter.h
@@ -0,0 +1 @@
+void pfilter_notify(int, int);
---- src/smtpd/pfilter.c.orig 2018-02-04 15:36:49 UTC
+--- src/smtpd/pfilter.c.orig 2021-05-06 19:00:00 UTC
+++ src/smtpd/pfilter.c
@@ -0,0 +1,19 @@
+#include "pfilter.h"