summaryrefslogtreecommitdiff
path: root/mail/postfix-current/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-current/Makefile')
-rw-r--r--mail/postfix-current/Makefile58
1 files changed, 40 insertions, 18 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index a37f2af05e3f..f1b63b89bea6 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -1,11 +1,11 @@
PORTNAME= postfix
-DISTVERSION= 3.9-20231030
-PORTREVISION= 1
+DISTVERSION= 3.9-20231112
+PORTREVISION?= 0
PORTEPOCH= 6
CATEGORIES= mail
-MASTER_SITES= http://ftp.porcupine.org/mirrors/postfix-release/ \
+MASTER_SITES= https://postfix-mirror.horus-it.com/postfix-release/ \
+ http://ftp.porcupine.org/mirrors/postfix-release/ \
http://de.postfix.org/ftpmirror/ \
- http://cdn.postfix.johnriley.me/mirrors/postfix-release/ \
http://www.artfiles.org/postfix.org/postfix-release/ \
http://mirror.lhsolutions.nl/postfix-release/ \
ftp://postfix.mirrors.pair.com/
@@ -23,20 +23,42 @@ LICENSE_NAME_IPL10= IBM PUBLIC LICENSE VERSION 1.0
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS_IPL10= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-FLAVORS= default ldap sasl
-default_CONFLICTS_INSTALL= postfix-current-base-ldap \
- postfix-current-base-sasl \
- postfix-current-ldap postfix-current-sasl
-ldap_PKGNAMESUFFIX= -current-ldap
-ldap_CONFLICTS_INSTALL= postfix-current \
- postfix-current-base \
- postfix-current-base-sasl \
- postfix-current-sasl
-sasl_PKGNAMESUFFIX= -current-sasl
-sasl_CONFLICTS_INSTALL= postfix-current \
- postfix-current-base \
- postfix-current-base-ldap \
- postfix-current-ldap
+FLAVORS= default ldap mysql pgsql sasl sqlite
+default_CONFLICTS_INSTALL= postfix-current-base-ldap postfix-current-base-sasl \
+ postfix-current-ldap postfix-current-sasl \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sqlite postfix-current-base-sqlite
+ldap_PKGNAMESUFFIX= -ldap
+ldap_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-base-sasl postfix-current-sasl \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sqlite postfix-current-base-sqlite
+mysql_PKGNAMESUFFIX= -mysql
+mysql_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sasl postfix-current-base-sasl \
+ postfix-current-sqlite postfix-current-base-sqlite
+pgsql_PKGNAMESUFFIX= -pgsql
+pgsql_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-sasl postfix-current-base-sasl \
+ postfix-current-sqlite postfix-current-base-sqlite
+sasl_PKGNAMESUFFIX= -sasl
+sasl_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-base-ldap postfix-current-ldap \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sqlite postfix-current-base-sqlite
+sqlite_PKGNAMESUFFIX= -sqlite
+sqlite_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sasl postfix-current-base-sasl
COMMENT_ldap= (with OpenLDAP support)
COMMENT_sasl= (with Cyrus SASL support)