summaryrefslogtreecommitdiff
path: root/japanese/libtomoe-gtk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/libtomoe-gtk/Makefile')
-rw-r--r--japanese/libtomoe-gtk/Makefile37
1 files changed, 30 insertions, 7 deletions
diff --git a/japanese/libtomoe-gtk/Makefile b/japanese/libtomoe-gtk/Makefile
index e7c65111bd38..b1469f961f69 100644
--- a/japanese/libtomoe-gtk/Makefile
+++ b/japanese/libtomoe-gtk/Makefile
@@ -6,21 +6,44 @@
#
PORTNAME= libtomoe-gtk
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.6.0
#PORTREVISION= 0
CATEGORIES= japanese
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR=tomoe/23909
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=tomoe
+DISTNAME= tomoe-gtk-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= ume@FreeBSD.org
COMMENT= TOMOE GTK+ library
-LIB_DEPENDS= tomoe.1:${PORTSDIR}/japanese/tomoe \
- gucharmap.6:${PORTSDIR}/deskutils/gucharmap
+LIB_DEPENDS= tomoe.1:${PORTSDIR}/japanese/tomoe
USE_GNOME= lthack gnomehack gtk20
GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+OPTIONS= GUCHARMAP "Compile with gucharmap" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GUCHARMAP)
+CONFIGURE_ARGS+=--with-gucharmap=no
+PLIST_SUB+= GUCHARMAP="@comment "
+.else
+LIB_DEPENDS+= gucharmap.6:${PORTSDIR}/deskutils/gucharmap
+PLIST_SUB+= GUCHARMAP=""
+.endif
+
+.if exists(${LOCALBASE}/libdata/pkgconfig/pytomoe.pc)
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
+ pyexecdir=${PYTHON_SITELIBDIR}
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+=--with-python=no
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.include <bsd.port.post.mk>