summaryrefslogtreecommitdiff
path: root/graphics/py-blockdiag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-blockdiag/Makefile')
-rw-r--r--graphics/py-blockdiag/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/graphics/py-blockdiag/Makefile b/graphics/py-blockdiag/Makefile
index ec63513063f2..6b2e4f093742 100644
--- a/graphics/py-blockdiag/Makefile
+++ b/graphics/py-blockdiag/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= blockdiag
-PORTVERSION= 1.1.1
-PORTREVISION= 2
+PORTVERSION= 1.1.2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -36,7 +35,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= README.txt
PORTEXAMPLES= *
-OPTIONS= PDF "Enable PDF output" On
+OPTIONS= PDF "Enable PDF output" On \
+ IPAFONT "Use IPA Font as default" Off
.include <bsd.port.options.mk>
@@ -44,6 +44,13 @@ OPTIONS= PDF "Enable PDF output" On
RUN_DEPENDS+= ${PKGNAMEPREFIX}reportlab2>0:${PORTSDIR}/print/py-reportlab2
.endif
+.if defined(WITH_IPAFONT)
+RUN_DEPENDS+= ${LOCALBASE}/share/font-ipa/ipag.otf:${PORTSDIR}/japanese/font-ipa
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/src/blockdiag/utils/bootstrap.py
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}