summaryrefslogtreecommitdiff
path: root/graphics/ksaneplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ksaneplugin/Makefile')
-rw-r--r--graphics/ksaneplugin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/ksaneplugin/Makefile b/graphics/ksaneplugin/Makefile
new file mode 100644
index 000000000000..6f6bd0a44128
--- /dev/null
+++ b/graphics/ksaneplugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ksaneplugin
+# Date created: 5 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ksaneplugin
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= graphics kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE 4 plugin for scanning through libksane
+
+LIB_DEPENDS= ksane.0:${PORTSDIR}/graphics/libksane
+
+CONFLICTS= kdegraphics-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= dbus qmake_build moc_build uic_build rcc_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>