summaryrefslogtreecommitdiff
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index d1279b994368..281657cbb67a 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
OPTIONS= JPEG "Enable jpeg image support" on \
@@ -47,7 +47,7 @@ CONFIGURE_ARGS+= --without-x
PKGNAMESUFFIX+= -nox11
PLIST_SUB= X11="@comment "
.else
-USE_XLIB= yes
+USE_XORG= x11 sm xext
PLIST_SUB= X11=""
.endif