summaryrefslogtreecommitdiff
path: root/graphics/dcraw-m/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dcraw-m/Makefile')
-rw-r--r--graphics/dcraw-m/Makefile45
1 files changed, 20 insertions, 25 deletions
diff --git a/graphics/dcraw-m/Makefile b/graphics/dcraw-m/Makefile
index 5d63feb463e5..78770fd21db4 100644
--- a/graphics/dcraw-m/Makefile
+++ b/graphics/dcraw-m/Makefile
@@ -2,48 +2,43 @@
# $FreeBSD$
PORTNAME= dcraw-m
-PORTVERSION= 9.17
-PORTREVISION= 1
+PORTVERSION= 9.22
CATEGORIES= graphics
-MASTER_SITES= https://dx.burplex.com/dcraw-m/ \
- http://www.waitman.net/dcraw-m/
+MASTER_SITES= GH
MAINTAINER= waitman@waitman.net
COMMENT= Modified Decoder for RAW files from digital cameras
-BROKEN= Unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2014-11-26
+LICENSE= GPLv2
LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms.so:${PORTSDIR}/graphics/lcms \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
-PLIST_FILES= bin/dcraw-m
-
-OPTIONS_DEFINE= OPTIMIZE_O3 OPTIMIZE_O4
-OPTIMIZE_O3_DESC= Use O3 with clang (O4 not working)
-OPTIMIZE_O4_DESC= Use O4 with gcc
+USE_GITHUB= yes
+GH_ACCOUNT= waitman
+GH_PROJECT= dcraw-m
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 1392579
-.include <bsd.port.options.mk>
+USES= pkgconfig
-.if ${PORT_OPTIONS:MOPTIMIZE_O3}
-CFLAGS+= -O3
-.else
-.if ${PORT_OPTIONS:MOPTIMIZE_O4}
-CFLAGS+= -O4
-.endif
-.endif
+CFLAGS += -Wall -Werror -I${LOCALBASE}/include \
+ `MagickWand-config --cflags --cppflags` \
+ -DMAGICKCORE_HDRI_ENABLE=0 \
+ -DMAGICKCORE_QUANTUM_DEPTH=16
+LDFLAGS += `MagickWand-config --ldflags --libs` -lm -llcms2 -ljpeg \
+ -ljasper
+LIBS += -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ImageMagick-6
-LDFLAGS+= -L${LOCALBASE}/lib -lm -ljasper -ljpeg -llcms -lMagickWand-6.Q16
+PLIST_FILES= bin/dcraw-m
do-build:
- cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+ ( cd ${WRKSRC} ; \
+ ${CC} ${CFLAGS} ${LIBS} ${LDFLAGS} -o ${PORTNAME} ${PORTNAME}.c )
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>