summaryrefslogtreecommitdiff
path: root/games/fuhquake/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/fuhquake/files/Makefile')
-rw-r--r--games/fuhquake/files/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/fuhquake/files/Makefile b/games/fuhquake/files/Makefile
index 589bfc987e0f..bb65bf3408c8 100644
--- a/games/fuhquake/files/Makefile
+++ b/games/fuhquake/files/Makefile
@@ -18,7 +18,7 @@ DO_CFLAGS += -DNO_WINDOWED_MOUSE
.undef WITHOUT_X86_ASM
.endif
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
DO_CFLAGS += -Did386
.endif
@@ -116,7 +116,7 @@ CL_COMMON_OBJS = \
rulesets.o \
utils.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_COMMON_AS_OBJS = \
cl_math.o \
math.o \
@@ -154,7 +154,7 @@ CL_SOFT_OBJS = \
r_surf.o \
r_vars.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SOFT_AS_OBJS = \
d_draw.o \
d_draw16.o \
@@ -192,7 +192,7 @@ CL_GLX_OBJS = \
CL_SVGA_OBJS = vid_svgalib.o
-.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
CL_SVGA_AS_OBJS = d_copy.o
.endif