summaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index cf8d63156cd3..d5ed3764e644 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.39.0
-PORTREVISION?= 1
+PORTVERSION= 7.40.0
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -165,6 +164,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|; s|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|include <gssapi.h>|include <gssapi/gssapi.h>|' ${WRKSRC}/lib/curl_gssapi.h ${WRKSRC}/lib/urldata.h
+ @${REINPLACE_CMD} -e 's|gss_nt_service_name|GSS_C_NT_HOSTBASED_SERVICE|' ${WRKSRC}/lib/curl_sasl_gssapi.c
post-install:
.if !defined(BUILDING_HIPHOP)
@@ -177,7 +177,7 @@ post-install:
cd ${WRKSRC}/docs/examples/ && ${INSTALL_DATA} README Makefile.example makefile* *.c *.cpp ${STAGEDIR}${EXAMPLESDIR}/
.endif
-x-regression-test test: build
+regression-test test: build
.if !${PORT_OPTIONS:MPROXY}
@${ECHO_MSG} "******************************************"
@${ECHO_MSG} "* You have disabled curl proxy support. *"