summaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-kmod
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox-ose-kmod')
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_Support_freebsd_Makefile13
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetAdp_freebsd_Makefile13
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetFlt_freebsd_Makefile13
3 files changed, 39 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_Support_freebsd_Makefile b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_Support_freebsd_Makefile
new file mode 100644
index 000000000000..c817eeda02bd
--- /dev/null
+++ b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_Support_freebsd_Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/VBox/HostDrivers/Support/freebsd/Makefile
++++ src/VBox/HostDrivers/Support/freebsd/Makefile
+@@ -174,5 +174,7 @@
+ SRCS += \
+ log-vbox.c
+
++MK_CLANG_IS_CC ?= no
++
+ .include <bsd.kmod.mk>
+
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetAdp_freebsd_Makefile b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetAdp_freebsd_Makefile
new file mode 100644
index 000000000000..ea1eb1011a15
--- /dev/null
+++ b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetAdp_freebsd_Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/VBox/HostDrivers/VBoxNetAdp/freebsd/Makefile
++++ src/VBox/HostDrivers/VBoxNetAdp/freebsd/Makefile
+@@ -32,5 +32,7 @@
+
+ SRCS += device_if.h bus_if.h
+
++MK_CLANG_IS_CC ?= no
++
+ .include <bsd.kmod.mk>
+
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetFlt_freebsd_Makefile b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetFlt_freebsd_Makefile
new file mode 100644
index 000000000000..45be0975d4fb
--- /dev/null
+++ b/emulators/virtualbox-ose-kmod/files/patch-src_VBox_HostDrivers_VBoxNetFlt_freebsd_Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/VBox/HostDrivers/VBoxNetFlt/freebsd/Makefile
++++ src/VBox/HostDrivers/VBoxNetFlt/freebsd/Makefile
+@@ -35,5 +35,7 @@
+
+ SRCS += device_if.h bus_if.h opt_netgraph.h
+
++MK_CLANG_IS_CC ?= no
++
+ .include <bsd.kmod.mk>
+