summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 8cc2b7880dfd..e0fc0971b363 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= QEMU CPU Emulator - development version
LICENSE= GPLv2
HAS_CONFIGURE= yes
-USES= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
+USES= cpe gmake pkgconfig bison perl5 python:2,build ssl tar:bzip2
USE_PERL5= build
USE_XORG= pixman
USE_GNOME+= cairo glib20
@@ -72,6 +72,7 @@ PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto
CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
--disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \