summaryrefslogtreecommitdiff
path: root/editors/tea
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tea')
-rw-r--r--editors/tea/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 7aa23033fd28..5fc8f85f515f 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -18,7 +18,7 @@ OPTIONS_SINGLE_TOOLKITS= QT4 QT5
OPTIONS_DEFINE= DOCS
OPTIONS_GROUP= SPELL
OPTIONS_GROUP_SPELL= ASPELL HUNSPELL
-OPTIONS_DEFAULT= QT4 ASPELL HUNSPELL
+OPTIONS_DEFAULT= QT5 ASPELL HUNSPELL
USE_GL= gl
USE_LOCALE= en_US.UTF-8
@@ -45,6 +45,13 @@ ASPELL_QMAKE_OFF= CONFIG+=noaspell
HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_QMAKE_OFF= CONFIG+=nohunspell
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQT4}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/tea ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/icons/tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps