summaryrefslogtreecommitdiff
path: root/editors/tea
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tea')
-rw-r--r--editors/tea/Makefile9
-rw-r--r--editors/tea/distinfo6
-rw-r--r--editors/tea/files/patch-spellchecker.h11
3 files changed, 6 insertions, 20 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 9a6ca52d983b..814cf5b02d6b 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tea
-PORTVERSION= 46.0.0
+PORTVERSION= 46.2.0
CATEGORIES= editors
MAINTAINER= danilo@FreeBSD.org
@@ -12,6 +12,8 @@ LICENSE= GPLv3
BROKEN_powerpc64= fails to link: spellchecker.o:(.text+0xd2c): undefined reference to Hunspell::remove(std::string const&)
+USES= gl pkgconfig:build qmake
+
OPTIONS_SINGLE= TOOLKITS
OPTIONS_SINGLE_TOOLKITS= QT4 QT5
OPTIONS_DEFINE= DOCS
@@ -19,7 +21,6 @@ OPTIONS_GROUP= SPELL
OPTIONS_GROUP_SPELL= ASPELL HUNSPELL
OPTIONS_DEFAULT= QT4 ASPELL HUNSPELL
-USES= gl pkgconfig:build qmake
USE_GL= gl
USE_LOCALE= en_US.UTF-8
@@ -45,10 +46,6 @@ ASPELL_QMAKE_OFF= CONFIG+=noaspell
HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_QMAKE_OFF= CONFIG+=nohunspell
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/tea ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/icons/tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps
diff --git a/editors/tea/distinfo b/editors/tea/distinfo
index 7d22c987e210..fd7832d6dcfa 100644
--- a/editors/tea/distinfo
+++ b/editors/tea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537107620
-SHA256 (psemiletov-tea-qt-46.0.0_GH0.tar.gz) = 23211e55658e285e0b71f54e06313353ba2bbd8886f53fa666fce25acff14897
-SIZE (psemiletov-tea-qt-46.0.0_GH0.tar.gz) = 507924
+TIMESTAMP = 1537985980
+SHA256 (psemiletov-tea-qt-46.2.0_GH0.tar.gz) = fc0137ed32946b4f544ea2ac1c9e44974b89df2b043cfabac11bb2bd65687069
+SIZE (psemiletov-tea-qt-46.2.0_GH0.tar.gz) = 504553
diff --git a/editors/tea/files/patch-spellchecker.h b/editors/tea/files/patch-spellchecker.h
deleted file mode 100644
index 27fa5d4c0c30..000000000000
--- a/editors/tea/files/patch-spellchecker.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- spellchecker.h.orig 2016-09-16 19:56:10 UTC
-+++ spellchecker.h
-@@ -100,7 +100,7 @@ public:
- QString user_dir;
- QString lng;
-
-- char *encoding;
-+ const char *encoding;
- QString dict_dir;
-
- CHunspellChecker (const QString &lang, const QString &path = "", const QString &user_path = "");